Quick update on the 2026 repairs. I received the new front truck for the engine in the mail this morning. Truck has been installed and seems to be issue free thus far. Im still waiting on the green gem for the front marker light, should come in on Monday. Im having issues with the E - Unit still. Im posting a video of the engine malfunctioning when the E - Unit is switched out of a locked direction. If anyone has any solutions or advice to fix this it would be much appreciated! 

Also quick update on the Pullman passenger cars. The observation car has a damaged wheel in the back with what looks like a dent. Can this wheel be repaired or should I just replace it? Im also posting a video of the 2026 pulling the Pullmans to demonstrate the loud clicking noise the damaged wheel makes while running. 

Attachments

Images (5)
Videos (2)
trim.6C9427A6-EBB0-420D-8600-C8BBE20C6ECE
trim.F27800AA-24C8-4F65-9604-5380747C14A0
Original Post

I don’t think you have an E unit issue, you are missing a sliding shoe as your second contact on the middle rail.

Here is a picture of one of my 2026 locos showing the two contact shoes. The part number is 1661-33 contact shoe. With only one shoe, any momentary loss of contact cycles the e-unit. With two, if one shoe loses contact, the other should maintain power to keep the e-unit from cycling.B5A0999E-82DC-49E9-9204-9313DFAA70A2

Attachments

Images (1)
Last edited by Ross

Add Reply

Post
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×