Skip to main content

Question for the electronics experts out there: I have an rotary dumper project that I have been working on for some time. I have a Arduino sketch written that works fine on an UNO board but is defying me on the NANO. The NANO just doesn't seem to take the program when I download it. I get nothing when I run the thing. I even bought a new NANO but still have the same problem. What's wrong?? I've checked the wire connections several times but don't find anything wrong.

Thanks for any help you can give


Original Post

Replies sorted oldest to newest


Good advice from Bryce, check that you have "Nano" board selected in the Arduino IDE program.  I run Nano's on my layout to control accessories and something that I find helpful is do the development programing on a Nano.  It makes it easier when the time come to take your program from the breadboard to the train board, pinouts all are the same and it eliminates the problem of forgetting to change the loader over to a Nano board, speaking from experience here.

John also has a good point, I just received three Nano's from overseas and had to trash all three because they did not have a bootloader installed.  Thankfully they were cheap enough so putting them in the waste basket didn't sting much. Make sure if you do order from overseas that the Nano has the bootloader installed.  Have ordered several more with the bootloader installed and have not had any issues.

Good luck, hope this helps.


Add Reply


OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)

Link copied to your clipboard.