Bluetooth question--Lionel E6 Atlantic with Legacy and Bluetooth

I have a new PRR E6 Atlantic steam loco with Legacy and Bluetooth. Legacy operation works fine. I wanted to experiment with Bluetooth control, so I installed the LionChief app on my iPhone. On opening, the app is supposed to recognize the engine and connect automatically. Instead, the engine reacts with a brief interruption in engine sounds, then the app displays the message "no connected locomotive". I tried the troubleshooting steps in the User Manual, and also tried another iPhone, with the same result.

I'm guessing that the app works (or, is supposed to work) by reading engine data stored in the locomotive's Bluetooth firmware. Perhaps my engine is simply missing that data, which could possibly be restored without having to send the engine to Lionel. If I'm mistaken, there could be a larger problem with the engine's Bluetooth electronics.

Suggestions, insights, etc. will be appreciated.

TCA member since 1974.

Original Post

Not positive, but a couple of tech troubleshoot ideas-

Is Bluetooth turned on the iPhones? I turn mine off unless I need it

Try a layout power up with the legacy base unplugged. That will take the engine from conventional to , hopefully, Bluetooth mode.

 

Carl

Arctic Railroad

Don't have any Legacy/Bluetooth, but with the LC+/Bluetooth if the engine is not found automatically I click on the box at the top of the screen that has the picture of a generic steam engine.  That leads to the screen of available engines.  If my engine is there I click on the icon that looks like linked chain (left icon) and that connects the LC+ engine to the app.  Not sure if Legacy engine works the same.

I have this engine as well. The above poster is correct in how you connect it in the app. The key here is to only control it with one option at a time, Legacy, Bluetooth or the universal remote.

If you're having fun, you're doing it right.

I put the engine and tender on rollers on a test track connected to a Lionel transformer. This is with the entire layout, including Legacy base, turned off. On increasing transformer power, the loco starts up in conventional mode. I tried turning on track power both before and after starting the LC app on my iPhone. Still, the app says "no connected locomotive". There is a definite reaction from the engine while trying to connect, so I think that some form of Bluetooth is there.

Does this qualify as a good test? For the LC app to be able to identify a particular locomotive, it must read data stored in the engine. Is that correct?

Another possibility could be some type of interference. We have several other things in the  house that work by Bluetooth. I tried turning these off with no effect.

TCA member since 1974.

You may need to have the Legacy base connected and start the engine in Legacy before going to the app.  If you Google:   "Lionel's LEGACY Bluetooth Control - Demo"  you can see a You Tube video made by Lionel on using the app with Legacy engines.

Add Reply

Likes (0)


OGR Publishing, Inc. PO Box 218, Hilliard, OH 43026 330-757-3020
www.ogaugerr.com
×
×
×
×
×