Skip to main content

Greetings All,

 After hearing all of the problems with the Blue & Orange Box F40PH Diesels I decided to try the "Other Guy" and this one has a problem as well (or maybe it's me......nah).   I do the normal Pre-Trip Inspection and Lube and proceed to enter the locomotive into the MTH DCS Remote.  The remote looks at me and says "No Engine Found".   I tried to enter it a second time and "No Engine Found" shows on the display again.   I tried it in conventional mode and BINGO, it runs and sounds great.  Back to the remote for a third time guessed it......"No Engine Found".   FWIW, I checked all of the switches to make sure they were in the proper positions (They Were Not!)  So, one last time I tried to enter the engine and "No Engine Found" rears it's ugly head.   Strike three, yer out!!!!  Now for the Technical Stuff.  The locomotive is a BRAND NEW MTH Amtrak F40PH Diesel with PS-3, Item number 20-20685-1.  If there's somethin' I missed, please tell me so I can feel really stupid and get back to running trains.  BTW, I'll post some pics of my new layout as soon as I get this F40PH thingy figured out.  Oh yeah, all of my other MTH Locomotives run just fine and I have 10's over the whole layout when checking signal strength.  I hope I don't have to send her back.  As always, any help will be greatly appreciated!

 Chief Bob (Retired)

Happy Easter

Last edited by PUFFRBELLY
Original Post

Replies sorted oldest to newest

 throw the switches inside the engine to make sure they're not stuck halfway. ( make sure it's set to DCS and 3 rail)

Try adding the engine on a short piece of track as the only engine powered up. Sometimes the remote sees another engine and gets confused.

Make sure it plays shutdown sounds for a few seconds when you cut the power. If it doesn't, I believe the remote can't add it properly.

 I would still tether the remote incase something happened recently.

Ray Lombardo posted:

MTH engines can be finicky when they are first added.  In addition to the good advice above, I would take all the other locomotives off the track.  Sometimes, when adding a new MTH locomotive, the presence of other DCS locomotives or TMCC locomotives causes problems.  Why, I am not sure but it does.  

Yes I agree use a programming track or follow Ray's advice.... This could be a simple ID conflict&  hopefully the engine remains dark & silent when it first receives power indicating it's seeing the dcs signal.

Greetings All,

 First, thanks to those of you who responded to my predicament.   I tried all of your suggestions and as a result a new problem has surfaced.  When trying to Add The Engine on a  programming track it sat silent for a few seconds and all of a sudden the start-up sequence came on (sounds and no movement).  After killing the power, the sounds stayed on for a few seconds.   I tried using a tether between the remote and the TIU (I am only using 1 TIU at this time) as well.  Still, "No Engine Found".  It's lookin' more like a Road Trip back to MTH.  Am I right?

 Chief Bob (Retired)

Happy Easter  

Do a conventional reset and you should get it to add to your remote in DCS.  Do not let people tell you that will not work.  Try it and see for yourself.  Sorry Dave, I did not see your post.  Good advice.  

Guys, if you have good signal on your track, add the engine there.  The program track is not needed.  If your track signal is questionable, use a program track.  

Last edited by Marty Fitzhenry

Greetings All,

 Well, I think I've found the problem.  It's NOT the engines, it's the TIU!  I decided to test my theory by deleting an known functional engine already installed in the system.  When I tried to load it back into the system, guess what, "No Engine Is Found".  So I tried my Rev. G Back-up TIU and the same thing happened, "No Engine Is Found".  This was done on a separate Programming Track.  Here's the common denominator, both TIU's were successfully upgraded to the 5.0 software last year and I never tried loading an engine because I was dismantling my old layout.  Is there a possible problem that I am not aware of?  I tried the Reset (horn and bells) using a Z4K with no luck  I really need help on this one.  Thank you in advance!

 Chief Bob (Retired)

Happy Easter!

Here's the common denominator, both TIU's were successfully upgraded to the 5.0 software last year and I never tried loading an engine because I was dismantling my old layout.  Is there a possible problem that I am not aware of?

No, DCS 5.0 is absolutely not the culprit. Much more likely is a loose transceiver board in the TIU or the remote. This could have happened when you took the TIU and remote off the layout for upgrading and handled them differently than you do through normal use.

Connect the TIU's Remote Input port to the base of the remote with a 4-conductor (curly) telephone handset cord and see if things improve. If they do, we can proceed from there.

DCS Book CoverThis and a whole lot more is all in “The DCS Companion 3rd Edition!"

This book is available from many fine OGR advertisers and forum sponsors, or as an eBook or a printed book at MTH's web store!
Marty Fitzhenry posted:

Recover engine is no help if the engine never added.

I don't know Marty,,I know about the hard reset and ID 99 (trouble there) . I guess MTH doesn't test before shipping??

I think Barry's nailed it with the loose transceiver board. ( probably in the remote.)

Here's another thought   ..does the "read"  find the TIU??  without the tether? with tether?

Greetings Everyone,

 First, thank you all for your input and suggestions to correct my problem.  However, I think we are getting a little off course with the "loose boards in the TIU and Remote.  To be sure, I handle these items like the delicate instruments that they are, so loose boards are probably not the problem.  Here's what I DO know.  ALL of the functions worked with BOTH of these (Rev. L and Rev. G) on all of the engines previously installed.

  1. Both Remote/TIU pairs (Rev. L and Rev. G) were successfully upgraded to 5.0 and continued to function as expected until today.
  2. All functions of my "Test Engine" (MTH Premier Genset) functioned as expected using the Rev. L TIU and Remote that was upgraded last year.
  3. The Remote "Finds" the TUI with and without the use of a tether. The message displayed on the remote is as follows: "Found TIU Addr 1 With 0 AIU Boxes Connected". This is the case with both Remote/TIU pairs (Rev. L and Rev. G).
  4. I reset both the Remote and TIU (Rev. L) and when I tried to Re-Load the Genset , the following message appeared on the remote "No Engine To Add".


a). Power is off on programming track.

b). Engine is placed on programming track.

c).  Engine "clicks" when power is applied.

d). Attempt to enter engine into system.

e).  "No Engine To Add" is displayed on remote.

 At this point the Rev. L TIU/Remote pair will NOT allow me to load any engine into the system.  Folks, I'm at my wits end.  None of this makes any sense to me.  BIG THANKS!

 Chief Bob (Retired)

BTW, neither of the Remote/TIU pairs (Rev.L and Rev.G) will allow me to add any engines into the system.  When I try all I get on the remote display is; "No Engine To Add".  Again, these were both successfully Upgraded to 5.0 last year.  Strange really?

Last edited by PUFFRBELLY
RJR posted:

Delicate handling doesn't always preclude loose boards.  The simple test is whether tethering makes a difference.  Items a-e will occur even if remote is off.  If you're unwilling to "borrow" a handset cord from your wired phone to try tethering, then all I can say is mazel tov.


As stated in my above post, The Remote "Finds" the TUI with and without the use of a tether. The message displayed on the remote is as follows: "Found TIU Addr 1 With 0 AIU Boxes Connected". This is the case with both Remote/TIU pairs (Rev. L and Rev. G).

I do apologize.  I overlooked that.  When you did the conventional (1W5B) reset, did you have all DCS signal off the track and get 2 toots when you were done?

If you have this problem with 2 TIUs. I don't think you have a hardware issue.  I have some ideas based upon recent efforts to add 3 locos to a wifi app, but want to hold off suggesting this procedure.

New thought.  You said two remote/TIU pairs.  If the content of both remotes is not identical regarding locos and their IDs, you'll have a problem.  I suggest pick the remote whose keys best reflect your wishes for layout, and back it up to your PC, using Loader 5.0.  Then reset the other remote, which will clean out the data

Place one of the recalcitrant locos on an unpowered track.  Using the reset empty remote, try a read.  If no locos come up, try add engine.  If either gives you an engine, edit the engine address to some ID number you've never used.  Post results and we'll go on from there.

You said engine runs in conventional.  If you cut power to the track, do sounds continue for more than 5 seconds or so?  If not, bad supercap or battery, so engine can't hold an ID.


Is it possible you may have the red & black wires crossed at the track?  Not likely if the engine remains dark and silent but apparently with proto-3 it doesn't matter. However it does matter with proto-2 (red to center rail)

We know the read finds the tiu... so the remote and tiu are communicating.

You really can't check out the dcs signal  if you  can't add an engine.... I'm guessing this may be something simple we've overlooked.

Last edited by Gregg

Greetings All,

 After exhausting every possible fix I could think of, as well as the ones suggested by my fellow forum members, I believe the problem to be resolved.   I Re-Loaded the DCS 5.00 software into both of the TIU's and Remotes and I was able to enter both the Genset AND the F40PH.   WOO HOO!!   Again, I would like to thank everyone who took the time to respond to my call for help.   And a BIG thanks to Barry Broskowitz for taking time to expeditiously answer my emails.   As it has been said many times before, this is a great forum with many like minded folks that are willing to help when called on to do so!   Problem Solved!!

 Chief Bob (Retired)   

Hey guys,

I have two loops on TIU AND REMOTE  upgrade  6.1 . Both on z1000 bricks .  20 MTH engines scattered on the two loops.

Purchased a new Premier F7 proto3 .  I couldn't get it to add on the fixed one which was powered up with fixed 2.  Always had good luck adding engines this way amazingly.

The problem ended up ocurring when I shut down fixed 2 and used fixed 1 on a single 30 inch track.   No problem with the F7 being added but I had to reenter all the other engines back  to the active list when I put everything back to the two loops  DCS  . All were proto3 except one proto2 diesel. 

BIG surprise...... one GP30 Premier proto 3 from a lash up gets a  "no engine on track " .   It was listed in the inactive list with the other Gp30, but when i tried to move it back to the active list ,  it disappeared.        It just sits on the track with no indication of any function.

I did move it to a separate single track with a Z1000 and a Z controller.  It had full functions even smoke .

I did the horn and 5 bells reset and got the 2 horn reset signal.  I did this about a half dozen times with good success.

Moved the engine back on the two loop layout and fired everything up.   I couldn't find an issue with some of the engines on the active list that I tried to operate. ......."No engine on track " for the GP30 though. 

I kept trying the DCS reset and recover methods that have been on the forum so many times .........The GP 30 just sets there dark and lifeless.        I've repeated the whole conventional and command methods with the same previous results hoping for a miracle. 😩

Help , my brain hurts  🤕





Add Reply

The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
Link copied to your clipboard.