Skip to main content

Good morning Ladies and Gentlemen:

I have a RailKing "Imperial Challenger" Item No. 30-1818-1 Steam engine with Proto-Sound 3.0 that I won on a previous "Cabin Fever" auction of MTH production samples.

I have just gotten around to running it on my layout, and it starts-up perfectly using my MTH Z 750 transformer, then starts moving forward after pressing the direction button. After a couple of seconds of running at a slow/medium speed, it stops abruptly on the track, with all the wheels locked-up, for a couple of seconds, and then takes off again, only to do the same thing a couple of feet further down the track.

As I said, I am running this loco with my MTH Z 750 transformer, as it will not respond to my hand-held MTH DSC remote (50-1033). It just sits on the track after the "start-up" sequence, but will not move when I press the + (forward) speed toggle button on the remote. The whistle will not work, nor will the bell using the remote buttons, but everything (including the rear coupler) works perfectly using the horn and bell buttons on the transformer.

I have other RailKing locomotives (steam and diesel) with PS3, and the hand held remote (50-1033) operates all of them easily. I was thinking I need to do a "factory reset", and the procedure is clearly outlined in the Owners Manual that came with it, however information published on the "Hobby Speed" site on E-bay when purchasing the MTH Remote (50-1033) claims a full "Factory Reset" cannot be achieved using a transformer - extract attached:

  * Locomotives will ONLY operate with the DCS Remote Commander if they are set to the factory default settings. If the Factory default settings must be reset, the reset procedure must be done with a DCS Digital Command System (Item No. 50-1001). Using a conventional transformer with bell and whistle buttons to reset to Factory default settings will NOT properly reset the Proto-Sound 2.0 or 3.0 electronics to the correct address needed by the DCS Remote Commander to operate the locomotive.

My question are:     

Am I wasting my time trying to do a "Factory Reset" using my MTH Z 750 transformer so as to be able to run the Challenger using my 50-1033 remote?

Will the "Factory Reset" overcome the problem of the loco running and then stopping abruptly, every 3 feet or so for a couple of seconds, and then taking off again?

Peter.....Buco Australia.

Original Post

Replies sorted oldest to newest

I posted this yesterday (Sunday here in Australia), but have not received any response.

Is there someone out there (MTH Techs.....anyone) that can help answer my questions???

I have partially solved the "stop-start-stop-start" problem since yesterday. It appears to have something to do with the "speed control" feature. If I disable it (engine in neutral - horn - bell - bell on the transformer) the loco will run perfectly forward and in reverse, but every time I shut the loco down completely, and then re-start it again, everything is lost and I have to go through the process of turning off the speed control again.

Oh, and one other thing, I can't get the "chuff sounds" at all, right from when the loco starts moving, nor while it is running. The freight yard sounds play all the time, as well as the cab crew talk, even while it is running around the layout - very strange!

I think the PS3 board may be dodgy, but I'm no expert, that is why I would dearly love to do a full "factory reset" to see if I can get it back to where it should be.

Any help will be greatly appreciated, as there are no certified MTH repairers what-so-ever here in the "land down under".

Peter.....Buco Australia

Peter,

In my opinion the simultaneous existence of the motion problem and the chuff problem points to a poor relationship between the tachometer tape (black and white stripes on the flywheel), and the electronic detector that reads it.

Check to see if the detector is positioned closely enough to the tape on the flywheel.  If I recall it should be about 1.0 mm.  It's likely to be too far away presently, thus causing both problems at the same time.

Mike

Just an FYI on the resets - not sure about this helping your other problems?

There are two slightly different resets, DCS and conventional.  I believe you can do a conventional reset using the Z-750 controller. Conventional reset - 1 whistle and 5 bells with 1/2 second intervals, you hear 2 whistles if works. It might take several tries to get the timing of the whistle and bells just right.

The newer PS3 engines can be DCS factory reset using the DCS Remote Commander. Ps2 and older PS3 engines will need the full DCS system for a DCS factory reset. The DCS factory reset sets the factory defaults for use with the DCS Remote Commander.

Quoted here from an old post by Barry Broskowitz - Starting with the 2014 PS3 RTR sets, in both and HO and O gauge, the set engines should be able to be reset to factory default settings by pushing the following three buttons in this sequence:

SND, DIR, -

Last edited by rtr12

Thank you guys for responding.

Mike: I will have another look at the tach tape and reader distance tomorrow (Wednesday), and I will report back.

rtr12: Thanks for the link to the previous thread on this subject. I will try and do a reset using the hand-held remote following the sequence you have listed.......fingers crossed!!!!  I'll get back to you as well to let you know if it worked, or not.

Peter.....Buco Australia.

Good morning guys:

Here is the update on the troublesome "Challenger". Sorry for the delay, but life just keeps getting in my way lately.

rtr12: I had some success doing the factory reset using the hand-held remote. Got the two whistle sounds confirming the reset. The cab crew sounds came on full volume, even though the volume pod (under the tender) is only set at about one third.

I pushed the + end of the long speed button to get it moving, and it responded with just one press (strange...I normally have to press it three or four times to get the loco moving slowly). The loco starts moving very slowly for about 3 seconds, then continues to increase in speed to the point where it is travelling almost flat out....all this without me touching the + speed button again!!!!

I hit the "direction" button to stop the run-a-way loco, and it locks-up all the wheels and comes to a screeching stop. I hit the "direction" button again, and it goes in reverse slowly for about 3 seconds, and then off the run-a-way loco goes again until I hit the "direction" button to get it to stop.

All this time the "freight yard and crew chatter" sounds are playing at almost full volume during the "run-a-way" mode, but there is no "chuffing" sounds from the loco what-so-ever.

What is also happening during the "run-a-way" mode is the smoke unit is coming on all by itself. I do not have any smoke fluid in it yet, so I have it turned off using the smoke control pod under the tender, but this makes no difference, and the wick starts to burn and smoke!!!!

On the up-side.....the whistle and bell work fine using the respective buttons on the remote, and the crew sounds can also be activated pressing the "SND" button. The rear coupler can also be fired open using the "coupler" button, and pressing "-" on the speed button. Finally the "start-up" and "shut-down" sequence can also be successfully achieved using the button on the remote.

In summary.....some features can be made to work using the remote that couldn't be activated using the Z 750 transformer, and other things (speed, sound, and smoke) are completely out-of-whack. I have gone back to running the loco using my Z 750 transformer, and fore-going some of the features.

Mike: The reader is approx. 1mm away from the tach tape on the flywheel. I moved it closer by installing a rubber band around it and the body of the can motor to get it closer to the flywheel, but this made no difference at all. As I have outlined above, the loco starts up using the hand-held remote and moves slowly, then just keeps increasing in speed till it is a run-a-way train!!

Going back and using the Z 750, I still have to do a re-set and disable the "speed control" feature every time to get it to run properly from the throttle on the transformer.

I am more certain than ever I have a "problem" in the circuit board, and I will try out the new MTH Parts site and put a PS3 board in my shopping trolley using the"wish list" Mike keeps telling us about.

Thanks again guys.......Peter (Buco Australia)

I am not sure where you are at fully with this, but.  Pots only work conventional.  If using DCS must turn smoke off with the feature.

You can go in and unplug the smoke unit to remove it as an issue.  Problems like this can be a bad drawbar connection.  Bad terminal crimp on a wire to the drawbar either tender or engine.  Bad software install.  Bad board.  Bad motor drawing too much current.  Bad AC power in.   So very specific behavior needs to be reported to help, but had to diagnose this from afar.  I would concentrate on the wiring through drawbar and drawbar.

You won't see a PS-3 tender board for several months if not a year or more.  Production first, outstanding warranty next, Dealer order outstanding from old MTH company, followed by the new parts company.  G

Last edited by GGG

Add Reply

Post
This forum is sponsored by MTH Electric Trains
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×