Skip to main content

MTH PS3 Berkshire, 2021 Premier run; Was running normally, shut it down one day, now can't get it to fire up under DCS. I used the read track option, shows engine not on track. Attempted to delete the engine from the remote to add it back in, 'no engines to add', even though it is on the track. Disconnected the TIU and connected the Z4000 directly to the layout, the engine runs fine in conventional mode, and does not turn on at all in DCS, so I know it's seeing the DCS signal as it knows to wait for a command, yet the DCS system claims it isn't there. I did try moving it around the layout to several spots, same results each time, 'No Engines To Add'.

Original Post

Replies sorted oldest to newest

Take every other locomotive off of the track.  Sometimes multiple DCS or TMCC/Legacy locomotives being on the track will cause weird problems.  Also, if there are any accessory cars on the tracks, take those off too and try again.  You have moved it already.  Also try to unseat and re-seat the wireless drawbar.  

HTH.  MTH makes great locomotives but DCS can be a pain in the rear.  Reminds me of the old Windows 95.  Works pretty well most of the time, and once in a while could be a real pain.

Good luck.

Last edited by Ray Lombardo

Okay, so: Tried it again with no other engines on the track. Still nothing. Tried it on a test track, nada. Track signal test run off another engine showed great signal in spots, poor in others. I am of course attempting to program the Berkshire back in on the strongest signal zones. (This is a new layout, I am still sorting the signal issue)

Another oddity, may or may not be related? All the Lionel Legacy engines on the track lost all sound function all at once earlier (Still responded to all other commands and functions). Regained it with a reboot.

I usually can add an engine from anywhere on the layout. But I have noticed on some engines. As the search is on to find the engine to add. Sometimes you have to go by the saying. Wait for it. Many times I get the No Engine On Track. Rather than exit or shut the power down. Try waiting a bit. Eventually mine always add. I’m guessing that message must come on after a certain amount of time. But it seems the system keeps looking.

Still if you follow John’s advice in creating a programming track. With just a piece of track and no other tracks powered on. It should add. Just make sure unless you have an auxiliary  power supply. That Fixed One has power going in if your using another channel for the programming track.

Make sure the DCS/DCC switch did not get moved to DCC.  Since it runs in conventional, on a test track as stated true to add it, but delete the engine from the remote first.  If that does not work, go it engine setting and scroll down to recover engine and try that.

Maybe what ever glitch your layout had cause engine ID to go out of range.  G

Add Reply

The DCS Forum is sponsored by

OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)

Link copied to your clipboard.