Skip to main content

Time to see if I can sort this out.  At one point, I actually was successful in connecting the WiFi unit to my home network when I first got the WiFi unit.  However, when I'd cycle power it would no longer be connected.  I'm still using the same router, and now I can never get a connection.  The router is an Asus RT-AC66U. 

I also have tried connecting it to the Verison FIOS Motorola MI424WR router, same issue.

The WPS negotiation appears to take place but just not complete.  If I push the WPS button on the WiFi and not the router, the WiFi will blink for several minutes before giving up.  The same for the router, if I press it's WPS button and not the WiFi, it sits blinking trying to connect for some time.  If I follow the manual sequence and press the WPS on the WiFi and then on the router, the process "completes" in a few seconds, and both ends stop blinking and go to the idle state.  It seems clear that the router is seeing the WiFi box, but doesn't connect.

I have connected the MTH WiFi unit using the WPS, no sweat, linked right up.  I can also connect Android phones, Apple iPads, etc., just not my LCS WiFi.

I don't see any way to do a total "reset" of the WiFi unit.  What am I missing here?

 

Is there any way to manually connect, some devices have a client PIN code to connect, anything like that in the LCS WiFi unit?

Last edited by gunrunnerjohn
Original Post

Replies sorted oldest to newest

I'm sure I haven't maxed the connections, I've had many more devices connected at times.  The Asus RT-AC66U is a fairly high performance router, and should easily handle 40-50 connections without breaking a sweat.

The ASUS RT-AC66U is a 5th gen dual-band Wi-Fi router, and the launch platform for the new ASUS AiCloud service. Its speed reaches 1.75Gbps, utilizing the Broadcom 802.11ac Wi-Fi controller and working in 2.4GHz and 5GHz. The 5GHz band supports up to 1.3Gbps, exceeding current Gigabit wired transmission and 3X faster than 802.11n. The RT-AC66U offers smooth lag-resistant multitasking and super-fast streaming, while ASUS AiRadar intelligently strengthens wireless connections via powerful amplification, offering future-proof optimized performance.

As far as avoiding WPS, that's not possible with the Lionel LCS WiFi unit if you want to connect to a network and not run in Access Point mode. From the manual, the only way to connect to the network...

If your Wireless Router supports “WPS” (WiFi Protected Setup), then you may add LCS WiFi to your home network. Now your iPad (or other device) can seamlessly access the internet and run your layout. However, if your home network is busy, you may experience latency (slower response to your commands) when using the JOIN to NETWORK mode of operation.

I have used that ASUS RT-AC66U and it is a very nice router, I don't think that is going to be your problem. The web interface on that router may be able to help you troubleshoot the connection though.  You can monitor the current wifi connections, signal strength, and check to see if there are other networks close by that may be using the same wifi channels.  You can even imitate the WPS function without pressing the button on the router.

It's too bad the LCS doesn't have web interface that allows you to custom configure wireless connections to your home network environment so that you don't have to use WPS.

H1000

H1000 posted:

I have used that ASUS RT-AC66U and it is a very nice router, I don't think that is going to be your problem. The web interface on that router may be able to help you troubleshoot the connection though.  You can monitor the current wifi connections, signal strength, and check to see if there are other networks close by that may be using the same wifi channels.  You can even imitate the WPS function without pressing the button on the router.

It's too bad the LCS doesn't have web interface that allows you to custom configure wireless connections to your home network environment so that you don't have to use WPS.

H1000

I have tried following the progress of the connection on the router, but I don't see anything that helps.  The maddening thing is that once when I first got this, it actually connected.  I have checked to make sure I allow 802.11b connections, that seemed like a logical issue, but that's not it.

I live in a semi-rural setting, and my network is the big dog around here.  I see a couple of neighbors at very low levels, but they're on different channels.  I have fired off WPS from the WPS page, it reacts the same as when I use the back-panel WPS button.  I also have the latest firmware for the router.

I don't see anything pertaining to the LCS WiFi in my status in the router.

Yep, connects fine in AP mode, that's the only way I can use it.  I'm getting unimpressed by the LCS WiFi, it's a royal PITA to have it be it's own network, I have to change connections to use it, and then the iPad isn't on the Internet without swapping the WiFi connection back.  I can buy $10 cheap Chinese devices that connect to my network seamlessly, I am unimpressed that this unit doesn't work!

gunrunnerjohn posted:

 I can buy $10 cheap Chinese devices that connect to my network seamlessly, I am unimpressed that this unit doesn't work!

Are you thinking about a device that will connect wirelessly to the LCS and then wired to your Router? Basically a wireless bridge.

AFIK, the WPS protocol really hasn't changed much since the LCS was introduced. I could see some problems if you had some of the very early WPS equipment from 10 years ago.

Do you use WPA or WPA2 for wireless security?

The WiFi does not appear in any fashion in the router's lists.  No DHCP table entry for the WiFi.

I see this in the log, when I try to connect using WPS.  It goes through and obviously initially sees the WPS request.

May  4 19:52:22 rc_service: httpd 301:notify_rc start_wps_method
May  4 19:52:49 rc_service: watchdog 307:notify_rc stop_wps_method

It also thinks the connection was a success, from the WPS page.

However, when looking in the DHCP table, no connection for the WiFi, and obviously trace of it in the list of connected wireless devices.

Since WPS on this router works for every other WPS device I've tried, including the MTH WiFi unit, I have to conclude the problem is not on my end.

Attachments

Images (1)
  • mceclip0

My LCS works well using the wifi setting to an Apple router. Seems like early on I had some issues figuring out the best way to get it working and finally settled on wifi to the router. I think the instructions said that could be slow due to local traffic, but that has not been the case here.

Occasionally, I should add, there is the need for a search for an address.

Last edited by cjack
TedW posted:

Pardon me if you have done this. But in the lcs wifi manual .pdf page 14, it talks about changing the lcs wifi channel. You might check to make sure the router and lcs are on the same channel. PITA I know.  

That's for the AP feature, and you actually want it on a different channel.  I did, however, put that on the same channel as a stab in the dark, but I didn't really expect it to do any good.  As expected, no change.

cjack posted:

My LCS works well using the wifi setting to an Apple router. Seems like early on I had some issues figuring out the best way to get it working and finally settled on wifi to the router. I think the instructions said that could be slow due to local traffic, but that has not been the case here.

Occasionally, I should add, there is the need for a search for an address.

I never get a connection to the router, so no need to search for any addresses.

TedW posted:

John, it might just be time to go outside, walk around the stump three times , spit and bury a toad. 

I did that, didn't help.

I would agree that it seems to be pointing to the LCS WiFi module.  

I also have an LCS WiFi that's connected to my home network.  Its been connected and I haven't had any issues for about 2 years.  The only time it's required any attention was when I replaced my home router and I had to reconnect it.  I was able to reconnect without any difficulty.  

That experience rules out the LCS WiFi module retaining connection information that would prevent a connection to another network (router).  And it confirms that connecting to another network (router) is as straight forward as expected.  Which further supports the thought that the LCS WiFi module is not operating properly.

Maybe it just needs a trip to that spa/resort in Concord NC?

This doesn't likely help you a bit ... but I connected via wps first time.  Router is a linksys.  

After applying power to the LCS wifi connected to the base which I'd used previously only as an access point -- I selected the wps button on the router (via an admin utility).  Some linksys online documentation claimed I had 2 mins to form a wps connection with a device...

The admin utility indicated the router was waiting...

So I then flipped the switch on the LCS wifi to "join to network" from access point.

After that I depressed the wps button for a few seconds until I got a fast pulse on the green led ...

Moments after that my router claimed it was connected... and the green led went to its normal "heart beat" (slow pulse) pattern... 

But I didn't actually use it connected in this way-- meaning I didn't try to read any packets off the engines, etc.. didn't have time today for that ... maybe tomorrow. 

Due to the location of the router relative to the lcs wifi in my set up-- that is they are far apart with a bad signal to boot.  I'm not likely to keep it this way ...

John,

A couple of things I would try.

First, have you tried to disable the security altogether and see if it will connect?

Second, I seem to remember having a printer or something that was fussy about the type of encryption for WPA2.  I typically set mine to TKIP/AES but you may have some luck trying all 3 settings in there.

Finally this is a very rudimentary suggestion but you don't have any MAC filtering enabled do you?  

It sure seems weird it would work as an AP but not connect to the home network.

Tony

Last edited by Tony_V
H1000 posted:

The Site survey can be found when you click "WIRELESS" in the left column and the "SITE SURVEY" tab at the top of the page.

...snip...

 One more thing to try is to set you Wireless channel spacing from 40 MHz to 20 MHz. The LCS operates in the 20 MHz zone only and if your router is switching between them that may cause a problem.

Hope this all helps John!

H1000

My router doesn't have the site Survey, hence the source of my confusion.  It is updated to the latest firmware from Asus for the RT-AC66U.  As you can see, I already run at the 20mhz channel bandwidth setting.

 

Asus Site Survey

Here's the firmware I'm running, the latest on the Asus site for this router.

Asus Firmware

Attachments

Images (2)
  • Asus Site Survey
  • Asus Firmware
Tony_V posted:

John,

A couple of things I would try.

First, have you tried to disable the security altogether and see if it will connect?

Second, I seem to remember having a printer or something that was fussy about the type of encryption for WPA2.  I typically set mine to TKIP/AES but you may have some luck trying all 3 settings in there.

Finally this is a very rudimentary suggestion but you don't have any MAC filtering enabled do you?  

It sure seems weird it would work as an AP but not connect to the home network.

Tony

Well... disabling all my network security seems to be a generally bad idea.  If that's what it takes to connect the WiFi unit, something is seriously wrong!  First off, the whole point of WPS is to connect with security to the router, hence the name Wifi Protected Setup.  Also, WPS only works if you have WPA.

WPS stands for Wi-Fi Protected Setup and it is a wireless networking standard that tries to make connections between a router and wireless devices faster and easier. It works only for wireless networks that have WPA Personal or WPA2 Personal security.

No MAC filtering enabled.

gunrunnerjohn posted:
Tony_V posted:

John,

A couple of things I would try.

First, have you tried to disable the security altogether and see if it will connect?

Second, I seem to remember having a printer or something that was fussy about the type of encryption for WPA2.  I typically set mine to TKIP/AES but you may have some luck trying all 3 settings in there.

Finally this is a very rudimentary suggestion but you don't have any MAC filtering enabled do you?  

It sure seems weird it would work as an AP but not connect to the home network.

Tony

Well... disabling all my network security seems to be a generally bad idea.  If that's what it takes to connect the WiFi unit, something is seriously wrong!  First off, the whole point of WPS is to connect with security to the router, hence the name Wifi Protected Setup.  Also, WPS only works if you have WPA.

WPS stands for Wi-Fi Protected Setup and it is a wireless networking standard that tries to make connections between a router and wireless devices faster and easier. It works only for wireless networks that have WPA Personal or WPA2 Personal security.

No MAC filtering enabled.

Tony,

It's also not possible to connect the LCS WiFi without using WPS.  The only option for connection is to press a WPS Enable button. 

Ahh, yes the site survey function is not a part of the OEM ASUS firmware.  I am running a 3rd party firmware from Merlin. (https://asuswrt.lostrealm.ca/) It is based on the the OEM firmware from ASUS but adds more features and user "wants", one of which is the Site Survey function.

Your model is supported if you want to try it out, and gong back to the OEM ASUS firmware is just as easy as putting on the MERLIN firmware. You shouldn't lose any previously saved data or settings, but always make a backup just in case.

My whole thought process here is can the ASUS router see the LCS when the LCS is operating in AP mode. If not, maybe something can be adjusted on the router to see it.

H1000

gunrunnerjohn posted:
Tony_V posted:

John,

A couple of things I would try.

First, have you tried to disable the security altogether and see if it will connect?

Second, I seem to remember having a printer or something that was fussy about the type of encryption for WPA2.  I typically set mine to TKIP/AES but you may have some luck trying all 3 settings in there.

Finally this is a very rudimentary suggestion but you don't have any MAC filtering enabled do you?  

It sure seems weird it would work as an AP but not connect to the home network.

Tony

Well... disabling all my network security seems to be a generally bad idea.  If that's what it takes to connect the WiFi unit, something is seriously wrong!  First off, the whole point of WPS is to connect with security to the router, hence the name Wifi Protected Setup.  Also, WPS only works if you have WPA.

WPS stands for Wi-Fi Protected Setup and it is a wireless networking standard that tries to make connections between a router and wireless devices faster and easier. It works only for wireless networks that have WPA Personal or WPA2 Personal security.

No MAC filtering enabled.

I only recommend disabling the security for troubleshooting.  It just eliminates it as a potential issue.  However I wasn't aware that WPS requires WPA or WPA2 security (I don't use WPS often).  That kind of eliminates that as something you can try.  I would try the different encryption methods though.

Another thought is your wireless password.  Make it basic, a capital letter or 2 and a couple of numbers.  No special characters.  I have seen issues with some special characters.

Tony

Hi John
First of all let me say " I feel your pain". I worked on computers and
networks for 30 years and when something that seems SO simple doesn't
work, aggravation sets in. I don't have the same scenario that you have but
something we use to do years ago was "share and compare" like "stare and compare"
See if you can borrow a know good LCS that is working with WPS, and plug it into your
configuration. If you can connect to that, than your origional unit is defective.
May be have the guys at Lionel fix or replace it.
Good luck!

Joe

gunrunnerjohn posted:

The WiFi does not appear in any fashion in the router's lists.  No DHCP table entry for the WiFi.

I see this in the log, when I try to connect using WPS.  It goes through and obviously initially sees the WPS request.

May  4 19:52:22 rc_service: httpd 301:notify_rc start_wps_method
May  4 19:52:49 rc_service: watchdog 307:notify_rc stop_wps_method

It also thinks the connection was a success, from the WPS page.

However, when looking in the DHCP table, no connection for the WiFi, and obviously trace of it in the list of connected wireless devices.

Since WPS on this router works for every other WPS device I've tried, including the MTH WiFi unit, I have to conclude the problem is not on my end.

Have you tried pushing that Reset button?

 

Anywho, the problems you are facing is one of the biggest reasons I'm going to pass on the WiFi modules.  Even my Nest products allow me to manually configure their wireless information.  I think that's what Lionel should of done.  The unit will create it's own network you log into with the app, then use the app to configure the device then when you hit apply, it switches over to those settings.

sinclair posted:

Anywho, the problems you are facing is one of the biggest reasons I'm going to pass on the WiFi modules. 

I hope you don't assume that the MTH WIU module is subject to the problem GRJ is having with the LCS. The WIU has a web interface page that allows you to customize the Wireless settings and connections. Not to mention it also has a wired Ethernet port for the upmost reliable connection to a computer or home router. Plug it in to a laptop via a CAT 5 cable and configure it without fuss.

 

Add Reply

Post
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×