I just picked up a DCS Explorer and love it but while it operates my Protosound 2.0 locomotives just fine, it will not operate my Protosound 3.0 locomotive. The PS 3 locomotives PS 3.0 was installed by an authorized MTH tech a couple of years ago. Has anyone hear had a similar experience, do I possibly need to update the firmware in the Exploerer? Any help would be appreciated.

Original Post

Two questions:

1. Can the DCS Explorer not find the PS3 locomotive when you press read on the app?

2. How many locomotives do you have stored in the app/DCS Explorer? The DCS Explorer can only store 3 locomotives, unlike the TIU which can store 99. 

Santa Fe, All the Way

You should have not have power going to the track from the Explorer until you do something in the app. E.g. refresh, add an engine.

I don’t have any PS2 engines so I’m know why it does work correctly, but it would make me look at the problem being with the PS3 engine first.

if you power up the Explorer without engine on the track is their power?

 

Mark W

No there is no power without the engine on the track. I always open the app first to refresh it before plugging in the power but the app doesn't really seem to refesh but I cannot be sure. I definitely know that there is no power to the track if a locomotive is not present.

I tried loading sound files to the PS 3.0 engine as well and the TIU cannot find the locomotive. I tried everything recommended and nothing works. I contacted MTH but that don't have a solution for either problem. I have exhausted all means of getting any PS 3.0 locos going I am going to 86 them all and go back to PS 2.0. I am glad I dont have a problem with TMCC and Legacy.

Add Reply

Likes (0)
Post
The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
×