Skip to main content

Alright here goes, I have set up a layout on the living room floor for an amateur army men film scene that has taken me far to long to get to the point i am now at, with a LOT of help from my Dad I have worked my way through problem after problem, the switches, sections of track that would cause derailment, low voltage, now I think we've arrived at the last problem(hopefully, I don't know how much longer Dad can handle helping me...)

The ProtoSound3 2-6-0 mogul has all the DCS functions working, except for the fact that it won't move, I scroll the wheel, I press down on it, I hold down the boost button, nothing happens, except, once I got it moving, but it was too slow, and it stalled out on a switch, I don't know what I did, all I know is that I fiddled around with the remote before trying again to make the darn thing start moving. However, seeing this brought back a dim memory from several years ago of my earlier experiments with DCS, before dad insisted I put everything in storage until I actually needed it to film the scene in my movie. I remember having a process, a routine, with the DCS remote, that I needed to go through whenever I started the locomotive up before I could make it move, incredibly easy once you knew what to do. I only wish I was smart enough to write it down. in short, I've had this problem before, I've solved it before, I just need to remember how. I'll probably tease it out eventually(I might have to...) but it would be so much easier if someone else had the same problem and could tell me the solution. So, any takers? Please answer quickly, I'm going to have to put everything away again by the end of next weekend at the latest, and that would be a major setback.

Original Post

Replies sorted oldest to newest

He said PS-3.  Make sure draw bar is fully inserted in tender properly.  Assuming you have full voltage 18V to the track.  Call up engine, hit start up.  Scroll thumb wheel. 

Make sure that the engine lights, smoke, etc... are working.  Having tender sounds lights means tender board is fine and getting power, but if drawbar connection not right, the engine may not function.  Needs info from tender to work.

Feature or factory reset may be needed if engine is locked in neutral.  G

literally everything works properly except movement, and not only did I actually get the thing to move briefly before it stalled on a switch, but I as I said I have a dim memory from a few years back, before it went into storage, of having to do a certain sequence of actions on the dcs remote before it would move, incredibly simple once you knew what they were. Has anyone else had a similar problem with a similar solution? Also note that I'm afraid to reset it, as I no longer have the PS3 sound files for it, and thus I would need re-download them from the mth website, which I'm worried might be effectively dead.

Also note that I'm afraid to reset it, as I no longer have the PS3 sound files for it, and thus I would need re-download them from the mth website, which I'm worried might be effectively dead.

The website is just fine, it runs slow as usual but is still up with everything available. A reset won't require you to reinstall the sound file. It will simply set it back to all of the original factory settings as it came when it was new in the box. After you factory reset, it will be removed from the remote and you will need to add it back in before you can operate it.

There is another factor, my locomotive has a 3rd party whistle smoke effect added to it, with its own control chip, would resetting the locomotive permanently disable that effect?

I can't imagine that a factory reset would have anything to do with that feature.  Factory reset only resets user programmable features to the factory defaults.

I'm using the standard mth Z-1000 power block,

I do not have another engine, although I might be getting one within the week,

And no, I don't think I have a shop near me that could test my engine, maybe at the very edge of my range, but getting  the opportunity to schedule a drive is very unlikely to happen before my schedule gets to the narrow window I have to film the darn thing. I have until friday to work out this kink.

...okay, one last question, will a hard reset remove the sound files that I programmed into the locomotive and replace them with the ones that the ps3 chip had when it was factory new? because those sounds were the sounds of a diesel, and I don't think I have the means to re-install the sound files I need anymore.

A hard reset will not remove or revert your sound files. If you have internet access, A PC with Windows, and a working TIU, you have the means to install files on a PS2 or PS3 engine. You may need a few other minor items but they are not hard to obtain.

Last edited by H1000

Darn it, the diesel is factory new when I thought it was lightly used, there are notes all over saying that the wheels need lubricating before use, and don't know if the family has any oil of the right type, and Dads asleep right now. what oil is even good for model train lubrication? I hope it's WD40, but I've heard several times that WD40 and model trains don't mix. either way I've got to get that steam engine running by friday or I can't shoot my film scene.

Okay, I'm, about to do a hard reset  on the 2-6-0 mogul. I wanted to test the diesel as well, but for reasons already stated I won't be able to test the diesel for at least several more hours, if not till sometime tomorrow, time I don't have. since you all seem to agree that resetting the 2-6-0 mogul will not change the sound files to their factory defaults I have only 2 more worries,

1. I have a 3rd party whistle steam addon with it's own secondary smoke unit, will resetting the systems do anything to that?

2. if resetting the mogul doesn't work, what should I try next?

So i managed to test the diesel after all. and it worked, this means that the mogul is the element with problems and not the dcs system, before I reset the mogul however, my other point must again be mentioned, will resetting the mogul cause the 3rd party whistle steam addon to be disabled? I spent a lot of money on that whistle steam, It needs to work for my film. If I one of you experts can declare that the probability of such a thing happening is at least below the 50 percent mark. Then I can reset my mogul with far less stress.

1. I have a 3rd party whistle steam addon with it's own secondary smoke unit, will resetting the systems do anything to that?

2. if resetting the mogul doesn't work, what should I try next?

1. It shouldn't affect the whistle steam addon.

2. if the reset doesn't work, you'll be back at the same step you are at right now. Before worrying about the next steps, let's try this first. The reset may solve your problem and the next steps may not be needed.

Last edited by H1000

Well, the good news is that the locomotive is moving fine, the bad news is that I think BOTH smoke units have stopped working(I can hear the smoke units fan, but no smoke is coming out), although it might just be that I didn't put in enough smoke oil, but either way, I cannot spend all night bent over on my hands and knees fiddling with the thing, I'll continue again tomorrow. I only hope you all will still be there to help me.

Welp, dad and I confirmed that the whistle smoke is dead, i guess I'll have to use cgi and clever cutting. that being said, all I need now is for dad to glue the whistle piece in place(as it tends to fall off easily and there's no reason to remove it anymore) in a few minutes I am going to do a "dry run" of the scene, taking the locomotive around the living room and playroom with the full Tanarian (tan) military supply train behind it. Thank you for helping me, everyone, tell me: do any of you want to be named in the credits of my film?

Add Reply

The DCS Forum is sponsored by

OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)

Link copied to your clipboard.