Skip to main content

I was starting to have issues...slow response, then I couldn't access submenus,  all softkeys displayed only doppler.  One of the fixes suggested for the softkey issue was to delete the engine and re add it.  I can't delete it because of the wheel issue.  Also, I'm getting no engine, etc., errors to boot.  I tried a tether, no improvement.  I had heard a 'crack' a few days ago.  So, I took the remote apart thinking I would reset the board....here's what I found (Oh, no screw was behind the batteries when I replaced them....actually, until I started researching how to open it up, I never noticed the empty screw hole):

cracked cradle for thumb wheel. I tried using super glue failed gloriously.  I looked for a cradle replacement. No luck. Need advice:  should I just scrap this remote and move to my new one, or can this be salvaged.  Also, do you think I also have a TIU issue? 

IMG-4638IMG-4639IMG-4640

Attachments

Images (3)
  • IMG-4638
  • IMG-4639
  • IMG-4640
Original Post

Replies sorted oldest to newest

Did you already call MTH to find out if they had any cradles?  They were available around a month ago.

The new Thumbwheel full assemblies are supposed to be compatible with the old remotes as well, so you can try to go that route, assuming that can be obtained from MTH.(I've seen other's say they've recently received one, but I have not ordered one myself)

-Dave

Last edited by Dave45681

Add Reply

Post
The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×