Skip to main content

I am having a lot of problems with my DCS engines for about the last six months.  My layout is set up for TMCC and DCS and has run fine for 8 or 9 years.  Lately, engines that worked great for years now say they are not on the track.  I try deleting and re adding but then there is the "NO ENGINE FOUND" screen.  I have several engines (both photo 2 and 3 that perform just fine.  I ran one of the performing engines next to where I try to add engines and it shows a signal strength of 10.  At this point, 6 of my 15 or so MTH engines will not work with the DCS system.

I just received a Proto 3 steam engine back from repair from a reputable repair person and it would ad but I cannot cut the smoke off.  When I press the smoke button, the screen blinks once but the Smoke on or off display does not show up.  I tried using the smoke pot to turn it off but it did not change the output. Then I tried the volume pot but output was unchanged.

I have had the TIU for about 16 years.  It has been updated to 6.0.  Do the TIU's wear out?

I would appreciate your thoughts on what may have caused the change.

Thanks,

Don

Original Post

Replies sorted oldest to newest

Don, DCS can be engine specific and PS-3 can compound and effect other engines if the wiring internal is interfering with DCS signal transformer.  Since half your fleet has problems, you need to make sure the ones not working have clean wheels and good pickups.  Along with good charged batteries or BCR.

You may have a TIU that has sensitivity issues, but if your getting 10 all across the layout with a single engine chances are the TIU and track are fine.  If you add a Lionel engine or certain passenger cars or maybe even a PS-3 engine with issues it could kill the signal.  G

Thank you to all who have responded.  A little more information;

Most problems are with PS3 engines but the PS2 engines are fully charged

There are no other engines or lighted cars on powered track

I only have one TIU connected and powered

The track is clean

I have not checked the signal strength on all 300 feet of mainline but I do get 10 an the area i use to load engines

Update:  I have a TIU purchased in 2002 that lost fixed channel one so I found another used one about 2013 and had it upgraded to 6.0.  I was using the upgrade model when all these issues began to show up.  Last night, I re-installed the older unit using the three good channels.  I have been able to add four of the problem engines but the remote will still not find those engines and another PS3 engine (Southern 44 ton) now seems to not want to be found.

I have read here that the latest TIU's seem to function better.  I have been looking for newer model since Mike announced he was closing the company but have come up empty handed!

Will there ever be another run of these TIU's?

Don

Make sure your remote code and TIU are the same.  6.10 is the latest.  What REV is on the bottom of the TIU?  Rev L is the latest with USB port and a better signal then previous models.  Though older ones can work fine too.

While your track is clean, are you sure you connections are fine, no voltage drops at certain sections?  Testing signal strength with a single engine around the layout can be helpful.  G

Add Reply

Post
The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×