Skip to main content

I am getting the error message engine not on track.   I was running the engine a couple of weeks ago.  Tried to start it right where it stopped.   Got the error message.   No other issues with any other engines.  Moved the engine to various spots still same result.  No response at all.  

Confirmed power to track, confirmed start of other engines at that and various locations.

Did it just die on me?

Last edited by msp
Original Post

Replies sorted oldest to newest

Another key aspect of MTH to know and just keep in your back pocket of knowledge.

PS2 and PS3 DCS engines store the DCS ID as part of the shutdown process and depends on a functioning battery (in the case of PS2) or supercaps on a PS3 or a PS2 with a BCR or super capacitor. Again, when you add the engine command, the engine communicates back to the remote or app and that ID is stored in the remote as part of the add engine function. On the engine side- that ID is stored in current active running memory of the processor but is not yet stored in the storage system of the locomotive until the engine experiences a power shutdown sequence where the board powers down and is running off supercapacitors or battery (in the case of PS2) and the last few actions of the firmware writes the current settings in memory (including the engine ID) to more permanent storage so the next time the engine is powered it uses the new stored ID that should match what is in the remote.

The reason for saying this is, you are new and have a mixed fleet of unkown PS2 and PS3 engines. PS3 engines are unlikely to experience this problem where the ID is not updated, but on PS2, these engines are old enough that some may or may not have working battery systems. Again, it's possible that you perform an add engine sequence, all goes fine, you run the engine that entire session no problems. However, on a PS2 with a bad or failing battery, the next time you power that engine, the remote cannot find it at the last stored ID. You then do the add engine and it increments to the next available engine slot in your remote or app. You then have 2 listings of the same engine on different IDs. When you see this happen over and over, it could be a problem with that engine and is not the fault of your DCS TIU or remote, it's the battery system in that PS2 engine.



As such, I have a rule that regardless of where I got the engine or age, if it is a PS2 engine, I inspect the battery. If I think it might be more than 5 years old and even then, I tend to replace it either with a new battery or a supercapacitor replacement.

A test that is covered in every PS2 based engine manual says that under conventional operation, the engine must continue playing engine sounds completely until shutdown. If your remove track power and the engine sounds cut off instantly- that is a big warning the battery system may not be working.

Looking at BCR to replace the green battery.   Do I understand correctly with a BCR I need to charge it for a minute before each use?



After turning the power off to the track, the BCR will hold a charge for 2 to 3 hours, depending on the engine. If you have not operated the engine in 2 to 3 hours, power up the engine in the reset position, for one minute at 10 volts or more.

Add Reply

Post
The DCS Forum is sponsored by

OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)
www.ogaugerr.com

×
×
×
×
Link copied to your clipboard.
×
×