Skip to main content

I have a K-line Berkshire K3670-1426CC. Beautiful engine, perhaps my favorite (shh, don't tell the MTH Daylight this)...

I started it up this afternoon, and smoke started coming from the chassis. The previous night, I had run it without problem. It was still on the track where I ended last night's session. Opening up, I found the culprit: one of the boards was smoking. I think it's the motor control board? Opening the engine up, this is what it looks like, the smoking board is highlighted:

20240227_175011_edited

The wires going from the board to the motor have charred, along with some blackening of the board, transistors, and capacitors, seen here:

20240227_175028_edited



20240227_175238_edited

Attempting to pull the connector apart resulted in the connector base delaminating from the board. Char can be easily seen.

20240227_175847_edited



So.. Question for everyone. Is this engine toast? Can I get a replacement board? How would you go about fixing this?

Thanks in advance.

Attachments

Images (5)
  • 20240227_175011_edited
  • 20240227_175847_edited
  • 20240227_175238_edited
  • 20240227_175043_edited
  • 20240227_175028_edited
Original Post

Replies sorted oldest to newest

Classic K-Line cruise failure, I've seen a bunch of them and they all go up in flames in the same place.  It's a design flaw in the K-Line cruise module.

The fix is usually putting an ERR Cruise Commander M board in there.  If you're OK without cruise, you can go cheap and put a Lionel DCDR in, that'll set you back a fraction of what the ERR board will cost.

Add Reply

Post

OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)
www.ogaugerr.com

×
×
×
×
Link copied to your clipboard.
×
×