Skip to main content

I have a premier 5v PS2 steam engine with a BCR battery replacement unit and the engine runs great, BUT exhibits the following symptoms of an unknown condition:

- the TIU says the engine in "inactive", so I have to delete engine from the list and then add it back; once the transformer/TIU are powered off and later powered on the cycle repeats

- when the engine is "added" back, it is then recognized, but the name is "No engine name"

- when starting the engine (in neutral), the headlight and front marker lights are illuminated, but when it starts moving forward the headlight goes off and then briefly on and the marker lights appear to remain off; the backup light stays on in reverse

Would greatly appreciate a simple solution that hopefully doesn't involve a board replacement.  

Thanks,

Tom Jasper

 

Original Post

Replies sorted oldest to newest

@Tom Jasper posted:

Thanks gunrunnerjohn for your reply.  My first thought was to check the wiring as I removed the boiler to lube the gear box, but everything seems to be in order.  I also did a factory reset.

 

So I will now relearn how to load the sound file.  Thanks again for your insight and recommendations.  Tom

If it worked fine before you removed the boiler there is a very good chance you pinched a wire. Check for that first.

I have to agree with Lou, if this only happened after removing the boiler, stop running it and looked for pinched wires.

I will have another look at the wiring.  As I was tightening the gearbox lid (that had wire bundles attached) I noticed a wire was under a screw head.  Fortunately, I was able to move the wire before fully seating the screw.  

To clarify, if a wire is or was pinched, does this often times result in a broken wire beneath in the otherwise undamaged insulation? 

Thanks,

Tom

It's taken me awhile, but I have determined that there were two unrelated problems that were causing operational issues.  After running the steamer, I tested the BCR and it had a low voltage reading (as I recall it was a little less than 4v).  I replaced the BCR with a new MTH "green" battery.  The problem with the steamer being labeled as "inactive" on the DCSystem when on a powered track and not remembering it's name after a power cycle was solved with the new battery.

The flickering marker lights and headlight going off when moving while the smoke is ON, is a somewhat common problem that exists with these early 5v PS2 systems.  There were great replies provided on another post that I made regarding this issue.

Tom

Well, if the BCR isn't charging, I suspect the charging circuit of the 5V board may have a problem.  It'll run for some time on a new battery until it discharges that battery.

If you want to see if the charge circuit is working, get things all hooked up and connect a voltmeter to the battery leads while it's still connected to the locomotive electronics.  Apply track power.  If the voltage doesn't start moving up when you do this, it's not charging.

Well, if the BCR isn't charging, I suspect the charging circuit of the 5V board may have a problem.

Hi John,

I applied 18v to the track and when I measured the battery leads I got a reading of 20v (seems odd that it would be higher than the track voltage).  I don't have a test station set up, so I wasn't able to observer the voltage at the battery as I increased power to the track.   

Tom

Yes John, I had the battery attached and I guess that would explain the higher voltage (dah).  I didn't disconnect the battery because I thought that I wouldn't be able to access the engine with the TIU.  Can I conclude that the charging circuit is okay or do I need to rerun the test with the battery disconnected.  Thanks for you help on this and the many other issues that I have posted about.  Tom

Actually, the battery being attached certainly does NOT explain the 20V reading!  I can't imagine getting that kind of reading with a good battery, more like around 9-10 volts maximum.  The higher the voltage is, the more the charge current goes up, and it's not a linear function!

Here's a little test with a 3.2v NiMh battery, the principle and ratios would be exactly the same for the 8.4v NiMh battery, just multiply the voltages by 3.5 as this is a 2-cell battery and the 8.4 volt one is a 7-cell battery.

You can see that only .6 volts more across the battery raised the charging current from nothing to almost an amp!  Had I cranked it up another few tenths, it would have shot up even faster!  I didn't want to ruin the battery, so I didn't increase it, I think this makes the point.

Using my 3.5 multiplication factor, the first voltage would be 8.54 volts, the second voltage would be 9.345, and the third would be 10.85.

In order for the voltage to actually make it to 20 volts, the current would have to be lots of amps!  Since the board has a 1A regulator, that ain't happening, so something is amiss with the 20 volt reading or the battery is certainly bad.

Attachments

Images (3)
  • mceclip0
  • mceclip1
  • mceclip2
Last edited by gunrunnerjohn

Tom,  The premier engine if the board is in the tender has a MUX set up.  The typical issue was flickering with smoke on, not going out on motion.  The mux set up generates the positive voltage for the engine lights and smoke, from the engine mux board.  2 diodes.  They get DC power from the motor leads.  Same way a PS-2 3V makes it even without MUX.  In that case those diodes are on the PCB at back of engine that tether connects too.  Still PV generated from Motor leads since one of them always has High DC voltage from the rectifier.

So can be several different things in the wiring.  From motor to MUX, mux to lights.  Some engines had pretty brittle wire and would not be the first time a bad solder joint on the purple wire or blue/orange for lights had a bad joint.

The markers are triggered off the mux by what the lights are doing.  So yes it can be a data issue coming from the tender mux.  Rare, other than poor joint on back of engine pcb for the HL input.  The HL and IL input from the PS-2 board goes to tender mux, which sends a single signal via the HL wire on the tether to the engine mux.  The engine mux decodes it to determine if you want HL on off, or Cab light on off.  Since a simple circuit, the markers follow that on off.

The actual LMK control on the remote, only controls tender markers directly.  Not engine markers.

The other thing is unstable 5V supply.  If engine running fine with speed control and smoke works, probably not wiring.  BUT if smoke fan motor noisy or going bad, it can cause issues with MUX function.  But it also usually causes issue with speed control, and PS-2 board function.

Lastly, could be the MUX mod too.  Depending on year and level of wiring in your engine.  It may need the mod.  G

Actually, the battery being attached certainly does NOT explain the 20V reading!

Mystery about the 20v reading solved!!  I set my voltmeter to AC current, tested the track and the reading was 18v.  Then, without thinking (a common occurrence these days), I measured the voltage at the battery while it was being charged and didn't change the voltmeter to DC.  Today, I decided to simply test the voltage of the battery while installed in the tender and got another reading of 20v while measuring AC voltage.  I switched the meter to DC and got a reading of 9.2v.  So, when the engine was on the track, the reading would have been 9v rather than 20v.  And, the battery shows a full charge, so I conclude that the charging circuit is working properly.

Thanks again John for your time and expertise in helping me.  Tom

Add Reply

Post
The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×