Skip to main content

I have a railking Y6B PS2 that I may have a bad board. I had a derailment and now the DCS can't find the engine. I tried restarting everything and even deleting it from the DCS and then trying to add a MTH engine, no luck. The engine headlight comes on and it has the sound. I picked it up about 5 years ago for only $250. I was thinking about upgrading to a PS3 board.

Is this something I can do or better left to a pro?

Is this what I need? Or will this only work on a working PS2 board?

Do I have other opions?

Part NumberPart NamePrice
50-1911PROTOSOUND 3.0 STEAM LOCOMOTIVE UPGRADE KIT / NOT INTENDED FOR G GAUGE$200.00/ea<form action="https://www.mthpartsandsales.com/shop/cart/addtocart" method="post" name="frmAddToCart_26217">
<input class="form-control" id="cartqty_26217" name="qty" placeholder="QTY" step="1" type="number" value="1" />
<button class="btn btn-primary" type="submit">Add</button>
</form>
Original Post

Replies sorted oldest to newest

You can try the recover engine feature in your 5.0 or above version in your DCS system. If the board was totally blown you would not have sounds.

Tried to recove it with no luck, then removed it from list and tried to add it with no luck.



@Chuck Sartor posted:

You can try the recover engine feature in your 5.0 or above version in your DCS system. If the board was totally blown you would not have sounds

Why don't you start with the exact product number of the locomotive you have?

You don't need to do the full upgrade, you can use the PS32 board to replace the existing board.  There are two part numbers for the PS32 board set, one to replace 5V boards and one to replace 3V boards.

After looking at it is it possible it was upgraded from 1 to 2, the tender seems to be missing a switch. It was working with DCS. I have the box some place I just have to do some digging.

thumbnail [1)thumbnail [2)thumbnail [3)thumbnail [9)thumbnail

Attachments

Images (5)
  • thumbnail (1)
  • thumbnail (2)
  • thumbnail (3)
  • thumbnail (9)
  • thumbnail

I doubt it was upgraded, that's a 5V board.  MTH sometimes used the same chassis in the early runs of PS/2 with holes for the PS/1 switches.  Also, it has the "official" PS/2 sticker on it.

If you've tried the Recover Engine function and done a factory reset, I'd be thinking you smoked the motor driver FET, I've seen several of those from a simple derailment or motor stall, they go quick on the 5V boards.

Attachments

Images (1)
  • mceclip0
@ConrailFan posted:

Thanks Vernon, I would have never have thought to use "Stacker".

It was in the announcements, the videos, and the tutorials, all posted right here in the forum when stacker PS3/2 boards suddenly became available again after the long shortage.

https://ogrforum.ogaugerr.com/...ts-arriving-in-march

These are key informational links regarding "Stacker" boards.

https://mthtrains.com/chainfiles

https://mthtrains.com/sites/de...20DOCUMENT_FINAL.pdf

Last edited by Vernon Barry

Add Reply

Post
This forum is sponsored by MTH Electric Trains

OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)
www.ogaugerr.com

×
×
×
×
Link copied to your clipboard.
×
×