Skip to main content

I got an Atlas PS3 44 tonner today and my MTH DCS will not find it. The switch on the loco is in the correct position. I was presuming  the "PS3"terminology to mean compatibility across both manufacturers. Did I misunderstand that?? Do I need to assign a TMCC address to the Atlas in order to use it with MTH?

If it matters, I us the iPad MTH app exclusively. It has never failed to find an MTH engine, or an addressed TMCC engine.

Thanks in advance! I'm hoping to run this engine tonight!

Original Post

Replies sorted oldest to newest

I intend this to be 3-rail. There is no 2/3 switch. Only a volume pot and the DCC/DCS switch.

The (scant) instructions said for 2-rail , remove the rollers and move the switch to DCC.

If you're trying to find this with the DCS system, regardless of 2-rail or 3-rail, the switch MUST be in DCS!  If the switch happens to be defective, the default open is DCC, so maybe it's just bad/flaky switch.

Let's go with the flakey switch. I moved it DCC and powered it. It lite right off as though it would in conventional. I did not try to move it. I powered down and put the switch back in DCS and then it could be "found" using Add New Engine, as they usually do.

Summed up....it's now working!!! I have other Atlas PS3 locos on order for late 2022 delivery. Let's see how that goes!  

Thanks to everyone who chimed in here!

I moved this to the Atlas forum BECAUSE it is discussing an Atlas product.  Come on...this was obviously NOT about a traditionally sized train.  Guys...help us out by reporting these instead of responding in a thread and not alerting us that it is in the wrong category.  Searching is already tough enough but it gets much harder if the topic is placed in a forum that most would not think to search.

@OGR posted:

I moved this to the Atlas forum BECAUSE it is discussing an Atlas product.  Come on...this was obviously NOT about a traditionally sized train.  Guys...help us out by reporting these instead of responding in a thread and not alerting us that it is in the wrong category.  Searching is already tough enough but it gets much harder if the topic is placed in a forum that most would not think to search.

OK and the real technical discussion was PS3.

So does this go under Atlas, or does it go under MTH control system for PS3?

Is there a new category for PS3 under Atlas?

OK and the real technical discussion was PS3.

So does this go under Atlas, or does it go under MTH control system for PS3?

Is there a new category for PS3 under Atlas?

This was directed to me by the moderator tonight.  Since the topic is about an ATLAS product, then it should have been in the Atlas forum.  If the discussion involved discussion / questions about PS3 only, then placement in the MTH category would have been fine but this was a question about a specific Atlas product and the system that it uses.

Let's go with the flakey switch. I moved it DCC and powered it. It lite right off as though it would in conventional. I did not try to move it. I powered down and put the switch back in DCS and then it could be "found" using Add New Engine, as they usually do.

Summed up....it's now working!!! I have other Atlas PS3 locos on order for late 2022 delivery. Let's see how that goes!  

Thanks to everyone who chimed in here!

In conversations with the Atlas folks, former MTH products they offer are exactly as MTH made them, no changes or revisions.

Last edited by BobbyD

Add Reply

Post
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×