Good afternoon,

I'm having an issue with an MTH Imperial Allegheny PS 3.0 (item no 30-1615-1).  If I place the engine and tender on the track with 18VAC and the draw-bar "unplugged", I have no issues.  But as soon as I plug the draw-bar from the locomotive into the tender, this causes a short. 

Realizing the issue seems to lie within the draw-bar, I checked continuity between each of the pins.  I measured continuity between the two pins shown in the picture below.

20190814_191535

Assuming I should not receive continuity between these two points,  I unplugged the draw-bar JST connector that mounts to the locomotive frame.   After doing that, I no longer measured continuity across those draw-bar pins.   My guess is the issue lies some where in the locomotive.

20190814_191843

Any ideas what might be going on?

 

 

Lionel Forever

Nick Marakovits

Attachments

Photos (2)
Original Post

Update*****  With the aforementioned JST connector unplugged, I then reconnected the locomotive drawbar back to the tender and turned track power on, there were no issues with shorting.  This isolates the issue to just the locomotive.

 

Lionel Forever

Nick Marakovits

Not necessarily true.   Looks like that engine has a jumper for the drawbar connection.  Removing that removed AC power going to tender board.  Remove 8 pin on the engine board, leave that connector in, and apply power.  If still shorted you have a bad tender board.  But you can also have damage to the boiler board.

Best as Alan stated to let a tech test both boards on the bench tester with golden boards.  PS-3 steam is unique in both board communicate and need to be tested separately.  G

MTH Authorized Service Center

Authorized ERR Dealer

Lionel Independent Repair Tech

Virginia Train Collectors Member

Add Reply

Likes (1)
Post
The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
×