Skip to main content

I've had problems with the new N/S F-7 270 (20-21357-1) that I documented in a separate thread. (https://ogrforum.ogaugerr.com/...0#149239177069242190)  I sent it to MTH Service and a young man in St. Joseph, MI, Samuel, worked on it.  At first he couldn't replicate the issue and called me. We talked about it. Then he called me back to explain that at his last test just before packing it up to send it to me, the engine exhibited the problem I described. He thought he had fixed it and sent it back.  When it arrived, I could not get it to be recognized, but when I put on other MTH engines it would wake up but I still could not load it into my Remote. Back to MTH. Again he called me, we talked and it was working fine for him but as we talked he put other MTH engines on the track, boom, it would not start. He said he never saw this issue before. He called back again to advise it was a bad board and he was confident he fixed it.  Well, it arrived today, and it runs like new.  I wanted to relay this story to show the dedication to fixing a problem this fellow exhibited. That's what I call "customer service."  Thanks for listening.

Original Post

Replies sorted oldest to newest

@ToledoEd posted:

I've had problems with the new N/S F-7 270 (20-21357-1) that I documented in a separate thread. (https://ogrforum.ogaugerr.com/...0#149239177069242190)  I sent it to MTH Service and a young man in St. Joseph, MI, Samuel, worked on it.  At first he couldn't replicate the issue and called me. We talked about it. Then he called me back to explain that at his last test just before packing it up to send it to me, the engine exhibited the problem I described. He thought he had fixed it and sent it back.  When it arrived, I could not get it to be recognized, but when I put on other MTH engines it would wake up but I still could not load it into my Remote. Back to MTH. Again he called me, we talked and it was working fine for him but as we talked he put other MTH engines on the track, boom, it would not start. He said he never saw this issue before. He called back again to advise it was a bad board and he was confident he fixed it.  Well, it arrived today, and it runs like new.  I wanted to relay this story to show the dedication to fixing a problem this fellow exhibited. That's what I call "customer service."  Thanks for listening.

 That is so good to hear Ed,  Apparently they have improved greatly from a few years back...  My experience with them was not steller.  Now that the repair service is up to par', shame they are dismantling shortly...

Add Reply

Post
This forum is sponsored by MTH Electric Trains
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×