Skip to main content

A little background...I recently upgraded my layout with LCS. I got a sensor track and a couple of ASC2 mods. At first I plugged the sensor track into my track with the DB9 cable. The green LED light will stay illuminated until I completely unplug/re-plug everything including my legacy base and then it will go off. Basically a system reset. This happens every time I unplug it from the DB9 cable. I finally get into the programming phase and it doesn’t take commands from the Cab2 remote. I decided to test it with the ASC2 mods and see if I had the same problem. The problem still remains with mods and trying to program them as well. I tried 2 separate PDI cable and the issue remains. I have version 1.52 on my remote and the track is powered by a 180 powerhouse and legacy powermaster. I have been in contact with Lionel and they seemed just as stumped. I have 5 legacy engines that have had no problems with programming or running with the 990. I followed the directions to a T when installing the sensor and the ASC2 mods. Any help will be great! 




Original Post

Replies sorted oldest to newest

"The green LED light will stay illuminated until I completely unplug/re-plug everything including my legacy base and then it will go off"

The correct behavior of the sensor track is to light both LEDs for a second or two on initial powerup (plugging in the LCS power jack) and then go out.   You may have a defective sensor track.

Do the ASC2s behave normally?

Is the Legacy Base firmware v1.52 or higher?  You mention the CAB2 rev level but the base requires a separate update.


The ASC2’s behave as the sensortrack does. On initial plug in, the mods will stay illuminated as well until I reset and unplug/replug the system a couple of different times. When I finally get them to the program process they don’t accept the commands. I have 3 of them and all 3 act the same even with different PDI cables. The base and the remote are both running 1.52. I know the instructions say 1.52 or higher, but is it possible that these accessories perform better on the newest version? Lionel has also recommended changing the channel on the base and remote but the accessories do not respond on higher channels and act as they were on lower channels. 


I have tried a single LCS device previously in the beginning because I was thinking along those same lines. All 4 of my LCS devices are acting in the same way. Is it possible it is a bad DB9 cable? There is nothing else connected to the serial port currently just the DB9 cable to the LCS device. I have the black modules coming in tomorrow to attempt to just update the software to 1.60. 

Have been playing with my LCS stack and watching the sensor track behavior ... If communications with the Legacy Base have failed, the sensor track green light stays on.  Parts that may have failed:

Legacy Base serial port, or the logic that receives/transmits commands via the serial port.

PDI power adapter's serial cable between the LCS devices and the Legacy Base. 

Add Reply

This forum is sponsored by Lionel, LLC

OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)

Link copied to your clipboard.