Skip to main content

A friend of mine opened his new-to-him Legacy Control System. All was well until he got to the wall wort. The case was cracked open as if it had been incorrectly assembled. After acquiring the requisite security bit, we opened the case completely. Nothing broken, and nothing amiss, save that the transformer core was out of place, which was easy to reseat. We did find a small PCB with 2 components on it. See pictures below. My question is, what are the components? I suspect at least one of them may be a fuse. I asked GRJ about them, but he could not cross reference the visible number with anything. Anyone know what these are?

Chris

LVHR

IMG_9396IMG_9397

Attachments

Images (2)
  • IMG_9396
  • IMG_9397
Original Post

Replies sorted oldest to newest

Agreed, the class cylinder is an axial lead fuse.

I was thinking the yellow disc may be a Bourns MF-R185 PTC resettable fuse.  It does appear to have the Bourns logo on it, and appears as if it may have the distinctive inward U bends on the leads.  Bourns MOVs I've found come in a blue package, but otherwise look similar to a PTC without the U bends in the leads.

I'm mostly guessing here.

Last edited by SteveH

If the yellow component is a Bourns MF-R185 PTC as I speculated, would these be the correct ratings of 1.85A Hold,  3.7A Trip and 30V max?

If the unit is used, as the OP may be implying, could it be that a previous owner installed it and left the original (possibly blown) fuse in place?

EDIT: The Bourns MF-RHT200-0 is a 2A PTC fuse and may be better suited for the Legacy Base2 transformer.

Last edited by SteveH

I opened up an older Legacy brick, one that came with a #993 expansion set.  All I found was a fuse in one leg of the secondary, it was a pretty robust fuse.  The markings weren't all that clear, so I torture tested it with a 10A current controlled bench supply.  It took around 9 amps to pop it.  I replaced it with a 2A hold, 4A trip PTC and buttoned it back up.  I won't ever have to open that one again...

FWIW, in looking at your picture again, it does appear that the PTC was just jumpered across a dead fuse, it's on the same pads as the fuse.   I went deluxe and removed the fuse.

  

Having just looked in side, my board is exactly the same as this one, it's on the secondary side.  The primary has no visible protection, but maybe the "in the windings" primary fuse is still present like some other supplies.

Attachments

Images (2)
  • mceclip0
  • mceclip1

I had a bad 993 once and tried an extra supply to see if it was the supply that went bad. I ended up with two bad supplies with blown fuses and a bad 993. I sent the 993 in and it came back intermittent. But this time it just went dark without blowing a fuse. That time it turned out to have a bad (intermittent) full wave rectifier which I replaced. It's been good ever since.

I blew a couple of these fuses doing the TMCC buffer.  I tap off the earth ground from the barrel of the P/S with a tether with a male and female 5.5/2.5mm barrel jack jumper.  A couple of the tethers had a short when you flexed them and took out the fuses.  I had to fix one for a customer of the TMCC Buffer with a PTC.  I zapped one of mine in the testing as well and had to fix that one.  This latest one was working fine, but I figured since I had it open, I might as well make any fix permanent.

I was able to get over to my buddy's house and use his security bit set to open my power supply. As GRJ stated, there is only one component attached to the board: the clear glass fuse. Based on the condition of my fuse, his is definitely blown. So now to order a couple of the PTC fuses (I have another Legacy power supply to do as well). I'll pull the glass fuses when I do them, as I like a neat job.

Chris

LVHR

Add Reply

Post
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×