We've completed a video that demonstrates the LionChief APP's new HotSpot mode.

Note that to be able to use this feature, the LionChief Universal Remote firmware must be updated to V1.3, which can be done by downloading the Universal Remote Updater APP for iOS or Android.

You also need to make sure your smart device has the latest version of the LionChief APP installed. Check the APP/Play store to see if you have an update available.

Also note that a new version of the Android LionChief APP has fixed a bug where RF LionChief Plus engines being operated with the HotSpot mode would not allow their smoke units to run.

Dave Olson

Director of Engineering

Lionel LLC

Original Post

Thanks for the video explanation, Dave.

A couple of question for Dave, or anyone that has a chance to play with the remote in hotspot mode: 

1. Does hotspot mode only control RF engines, or can you also control Bluetooth engines throught the hotspot?

2. Does it extend effective operating range? (i.e., phone to remote max distance + remote to train max distance = extra long distance...pic below to try to illustrate what I'm trying to ask)

Hotspot

 

Attachments

Photos (1)
Trainlover9943 posted:

If you're using the UR in hotspot mode. Can you use it to run trains with it or is it hotspot mode or running trains only but not both? 

The Universal Remote can only be in one mode at a time. So if in hotspot mode, it cannot run Bluetooth trains at the same time.

 

JD2035RR posted:

Thanks for the video explanation, Dave.

A couple of question for Dave, or anyone that has a chance to play with the remote in hotspot mode: 

1. Does hotspot mode only control RF engines, or can you also control Bluetooth engines throught the hotspot?    Only RF.

2. Does it extend effective operating range? (i.e., phone to remote max distance + remote to train max distance = extra long distance...pic below to try to illustrate what I'm trying to ask)   Yes, but only for RF engines.

 

Dave Olson

Director of Engineering

Lionel LLC

@Dave Olson thank you for the informative video! It was fun using my older RF Lionchief equipment using the app. I have a few minor glitch issues and suggestions:

1. Can we please not have max volume as the default when a loco connects? I previously used the remote to set the volume where I wanted it. But the app immediately cranks up my LC+ engines full blast,  waking up the whole house before I can turn it back down. Maybe default to medium-volume?

2. The "available engines" screen will only appear with the correct number of available engines for exactly 5 seconds. Then, the number of available engines drops back to zero. Perhaps it could time-out after say 10 or 15 seconds?

3. The bell button's "on/off" color status gets out of sync with the bell "on/off" operation. It is sometimes blue when the bell is off or vice-versa. The issue is that the button changes color faster than the bell can respond. Maybe have the button  color change  only occur after one's finger is on the button for a certain number of milliseconds?

4. Upon disconnecting LC+ steam locos, the engine sits there beeping, as it should. But the smoke fan motor turns on full blast and won't stop. This happens about half the time. It is a really odd glitch.

5. There are frequent disconnects. What is the distance limit from loco to U remote, and from LC app device to U remote? Can other Lionel products interfere with the  LC frequency spectrum? Do you have any advice as to whether there are bad placement locations for the U remote, such as too close to my  ZW-L, Legacy base, LCS Wi-Fi, or other LCS modules?

Thanks again for a great product, and making the app backwards compatible!

GregR posted:

1. Can we please not have max volume as the default when a loco connects? I previously used the remote to set the volume where I wanted it. But the app immediately cranks up my LC+ engines full blast,  waking up the whole house before I can turn it back down. Maybe default to medium-volume? I'll test this out to see what might be best. It comes down to preference. Other people may get annoyed that the volume would default lower and that they would have to go into the APP and increase the volume every time.

2. The "available engines" screen will only appear with the correct number of available engines for exactly 5 seconds. Then, the number of available engines drops back to zero. Perhaps it could time-out after say 10 or 15 seconds? This might be device specific. What device are you using? Android or iOS? What model?

3. The bell button's "on/off" color status gets out of sync with the bell "on/off" operation. It is sometimes blue when the bell is off or vice-versa. The issue is that the button changes color faster than the bell can respond. Maybe have the button  color change  only occur after one's finger is on the button for a certain number of milliseconds? This is again probably device specific.

4. Upon disconnecting LC+ steam locos, the engine sits there beeping, as it should. But the smoke fan motor turns on full blast and won't stop. This happens about half the time. It is a really odd glitch. This is odd. What engine did you see this happen on?

5. There are frequent disconnects. What is the distance limit from loco to U remote, and from LC app device to U remote? Can other Lionel products interfere with the  LC frequency spectrum? Do you have any advice as to whether there are bad placement locations for the U remote, such as too close to my  ZW-L, Legacy base, LCS Wi-Fi, or other LCS modules?

From the RF loco to the UR, the range is pretty good. I would say at least 50 feet. From the UR to the phone, it is completely dependent upon the Bluetooth module in the phone. Different makers use different modules, but we've seen an average of 30 feet. 

No other Lionel electronics should interfere with the Bluetooth or RF LionChief electronics.

 

Dave Olson

Director of Engineering

Lionel LLC

I tested the hotspot feature with 3 of my non-bluetooth LC and LC+ locomotives:

6-82828: UP GP38 LC+
6-82964: Milwaukee Road Hudson LC+
6-28653: Polar Express 10th Anniversary LC

The hotspot feature does work for all these locomotives, but it doesn't unlock any additional features. (i.e. individual volume control for the bell, horn, etc) As Dave indicates in his video, this is due to hardware limitations... which is perfectly understandable.

So while it's nice to have the option to run older non-bluetooth LC and LC+ locomotives via a smartphone or tablet, for me personally I'd prefer to just run them directly via the universal remote.

Some QA feedback for Dave Olson: When connecting to my LC PE 10th anniversary locomotive (6-28653) via hotspot the LC app just lists it as a generic diesel locomotive.   And the forward/reverse button on the app doesn't work for this locomotive in hot spot mode... it goes forward even when selecting to run the locomotive in reverse.  (tested from my iPhone 6s/iOS 12.4.4)

- Joe

 

Pittsburgh, PA

Joe_pgh posted:

 

Some QA feedback for Dave Olson: When connecting to my LC PE 10th anniversary locomotive (6-28653) via hotspot the LC app just lists it as a generic diesel locomotive.   And the forward/reverse button on the app doesn't work for this locomotive in hot spot mode... it goes forward even when selecting to run the locomotive in reverse.  (tested from my iPhone 6s/iOS 12.4.4)

Just tested this. Engine image pulls up and the direction button works fine. Used iPhone 6s.

Did you check that you have the latest version of the APP installed?

Dave Olson

Director of Engineering

Lionel LLC

Dave Olson posted:
Joe_pgh posted:

 

Some QA feedback for Dave Olson: When connecting to my LC PE 10th anniversary locomotive (6-28653) via hotspot the LC app just lists it as a generic diesel locomotive.   And the forward/reverse button on the app doesn't work for this locomotive in hot spot mode... it goes forward even when selecting to run the locomotive in reverse.  (tested from my iPhone 6s/iOS 12.4.4)

Just tested this. Engine image pulls up and the direction button works fine. Used iPhone 6s.

Did you check that you have the latest version of the APP installed?

Thanks Dave.  I'm running the LC APP v1.3.7x16.

I just tested this again, and it seems that in hotspot mode sometimes clicking the button to toggle from forward to reverse works, and sometimes it doesn't.  (and vice-versa)  I have the locomotive, universal remote, and my iPhone within a few feet of each other.  (So not an issue trying to get this working across a long distance.)  Not a big issue for me, as I prefer to just use the universal remote (in non hotspot mode) to control my locomotives directly.

- Joe

 

Pittsburgh, PA

Add Reply

Likes (4)
Post
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
×