Skip to main content

I have a SW 7. Running in Legacy mode. It all of a sudden it stopped taking any commands. I have tried to do a reset but it won’t take. When I turn power on to the track, it starts on it’s own and will idle few 10-15 seconds and then go to full rpm. Only sounds no movement, no horns or bells. Nothing works other than on its own starting  it’s self. Where can I start at trouble shooting  this? I have checked all the wiring and all seems good.  Any advice would be appreciated.

Original Post

Replies sorted oldest to newest

thanks for the advice on the titles. i kind of got my hand slap awhile ago because it was too long and need to be much shorter. but never the less, thank for your reply.

Richie, yes everything is off when i put it on the track.no blinking lights for codes. i have tried several different id numbers with no luck. i have 16 other Legacy engines that all work perfect. this one here is just being a bugger bear. but again, thanks for your reply

Dale, I'm fairly new to legacy, but old to troubleshooting electronics in general.  As you are probably aware, it could very well be a bad circuit board component, but before that assumption is made, I would suggest "exercising" the connectors inside the loco.  By this I mean, unplugging and reconnecting them, one at at time.  Oxidation between compression connections can build-up over time. Sometimes just disconnecting and reconnecting will get things working again.  Same for wire nuts.  And of course it's always a good idea to take good pictures of the connections from different angles before starting, in case there's a question later about where something goes.

Last edited by SteveH

Add Reply

Post
This forum is sponsored by Lionel, LLC
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×