Skip to main content

I have a SW 7. Running in Legacy mode. It all of a sudden it stopped taking any commands. I have tried to do a reset but it won’t take. When I turn power on to the track, it starts on it’s own and will idle few 10-15 seconds and then go to full rpm. Only sounds no movement, no horns or bells. Nothing works other than on its own starting  it’s self. Where can I start at trouble shooting  this? I have checked all the wiring and all seems good.  Any advice would be appreciated.

Original Post

Replies sorted oldest to newest

thanks for the advice on the titles. i kind of got my hand slap awhile ago because it was too long and need to be much shorter. but never the less, thank for your reply.

Richie, yes everything is off when i put it on the blinking lights for codes. i have tried several different id numbers with no luck. i have 16 other Legacy engines that all work perfect. this one here is just being a bugger bear. but again, thanks for your reply

Dale, I'm fairly new to legacy, but old to troubleshooting electronics in general.  As you are probably aware, it could very well be a bad circuit board component, but before that assumption is made, I would suggest "exercising" the connectors inside the loco.  By this I mean, unplugging and reconnecting them, one at at time.  Oxidation between compression connections can build-up over time. Sometimes just disconnecting and reconnecting will get things working again.  Same for wire nuts.  And of course it's always a good idea to take good pictures of the connections from different angles before starting, in case there's a question later about where something goes.

Last edited by SteveH


thanks for your help as it’s is the board. While waiting for Lionel to ship me a new board.       ( last one took 7 weeks to receive)  I bought another little switcher S-4 Alco. Ran great new out of the box for 5 days. No issues great little switcher to make up and brake downs trains. On the 6 th night I had been running 3-4 minutes , had it sitting at idle while another engine hooked up, looked over at it and smoke was bellowing out of the bottom, grabbed it off the track and the middle of the cab had melted to the smoke unit. Maybe I’m not supposed to run small engines?


I don't want to be offensive, but you complained earlier about people not responding to your requests for help.  Let's analyze your last post and see what might be the problem.

First, the only description of the item with issues is an "Alco S-4."  People that might want to help you need more to go on than that.  How about indicating manufacturer, product number, type of operating system (command or conventional) and any other detail that might be relevant to the situation?  Providing assistance should not require the assister to be a detective.

Second, you say that the "middle of the cab had melted to the smoke unit."  Now, that may certainly be the case, but I'm not aware of many smoke units being positioned close enough to an engine cab to cause melting, particularly when discussing diesel engines.  Could it be that you meant the engine body or hood had melted?  In any regard, pictures of the damaged unit would have been very helpful in at least starting a diagnosis.

Third, your last post had nothing to do with the original thread except the commonality of model engine problems.  Perhaps a new thread, titled "Bad Smoke Unit?" would get some suggestions of how to diagnose and fix the problem?

You are correct that many more people will look at concise thread titles, but they have to be a little more descriptive than just a product number.  I first looked at this thread because I thought some Lionel product might be for sale.

Just my 2 cents.


Last edited by PRR1950

Add Reply

This forum is sponsored by Lionel, LLC
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
Link copied to your clipboard.