Was at the LHS, forum Sponsor The Imperial Train Company, today and this gem was unboxed.  Lionel's Halloween RS-11.  This was a surprise for sure.  Lots of cool sounds and "scary" bells and whistles.  As fast as it was unboxed, it had to be boxed right back up again because it was purchased.  The sound was crisp and loud and the engine performed flawlessly.  

Marty

 

Below the Signature...

"Live Long and Prosper". Spock

 

Original Post

With the release of this, the Halloween steamer should be interesting.  These 2 locomotives could be big sellers for the second most celebrated holidays!  Both MTH and Lionel have significantly upped their Halloween offerings!

Marty

 

Below the Signature...

"Live Long and Prosper". Spock

 

I think part of the problem is the catalog and online description on Lionel's website have no mention of the Halloween themed sounds.  That's definitely a point which needs to be made as that is what "makes" this engine. 

Does anyone know if the LionelChief+ Halloween engines (both steam and diesel) have this same sound set?

-Greg

Member of the Brotherhood of the Crappy Basement Layout

Associate Member of the NJ Hi-Railers

Image result for nj hirailers logo

 

Grampstrains posted:
Greg Houser posted:

I think part of the problem is the catalog and online description on Lionel's website have no mention of the Halloween themed sounds.  That's definitely a point which needs to be made as that is what "makes" this engine. 

Does anyone know if the LionelChief+ Halloween engines (both steam and diesel) have this same sound set?

-Greg

You should read the catalog again.  It states right above the engine "Halloween themed crew talk and sounds"

Thanks, I shouldn't have assumed the catalogs would have information the website doesn't.

Fyi...I googled "Lionel Legacy diesel with Halloween sounds" and "Lionel Legacy Steamer with Halloween sounds". 

The diesel search took me here:

http://www.lionel.com/products...cy-rs-11-13-1933071/

No mention of the Halloween sounds.

The steamer search took me here:

http://www.lionel.com/products...acific-1031-6-85175/

No mention of Halloween sounds.

-Greg

Member of the Brotherhood of the Crappy Basement Layout

Associate Member of the NJ Hi-Railers

Image result for nj hirailers logo

 

Watch it on this loco...apparently the new Legacy RS-11's have the same spooky issue as the PA's: forgetting it's TMCC ID.

Greg Houser posted:

I think part of the problem is the catalog and online description on Lionel's website have no mention of the Halloween themed sounds.  That's definitely a point which needs to be made as that is what "makes" this engine. 

Does anyone know if the LionelChief+ Halloween engines (both steam and diesel) have this same sound set?

-Greg

Lionel Hollween Mikado w/LionChief Plus and Bluetooth

www.youtube.com/watch?v=OD49SJk9h_U

Doug W. posted:
Greg Houser posted:

I think part of the problem is the catalog and online description on Lionel's website have no mention of the Halloween themed sounds.  That's definitely a point which needs to be made as that is what "makes" this engine. 

Does anyone know if the LionelChief+ Halloween engines (both steam and diesel) have this same sound set?

-Greg

Lionel Hollween Mikado w/LionChief Plus and Bluetooth

www.youtube.com/watch?v=OD49SJk9h_U

Thank-you!

-Greg

Member of the Brotherhood of the Crappy Basement Layout

Associate Member of the NJ Hi-Railers

Image result for nj hirailers logo

 

Craignor posted:

Watch it on this loco...apparently the new Legacy RS-11's have the same spooky issue as the PA's: forgetting it's TMCC ID.

Where did you hear that?

Marty

 

Below the Signature...

"Live Long and Prosper". Spock

 

I read it on this forum:

Gunrunner John, 6/30/19, 10:56 AM, on the "Lionel Legacy PA Forgetting ID" thread:

"Apparently, the new Legacy RS-11 has the same issue with forgetting it's TMCC ID."

BobbyD posted:
MartyE posted:

Missed that Thanks.  All the more reason to purchase from a good LHS.

At the local store they all have the same issue Marty, they checked stock. 

Bummer, I wonder how many RCMC boards shipped with this flaw, I hope this isn't an epidemic!  So far it's the PA's and the RS11 models, but since the same board is in most Legacy diesels, this might be a torrent!

Both of my new RS11’s lose their ID, so yesterday when I went to start my train up, no go, as they both reset to ENG 1. So, I thought I’ll just flip the PRG/RUN on each one separately and reprogram them to their original ID without shutting the power off and on. To my surprise they both responded when I ‘set’ them. I hit Train 82  and off they went! Some of you may know this already but it was a learning experience for me! Also, you need to set them up in opposite directions than you normally would to have them operate in a train correctly. These are buggy, but with this new found procedure and the fact that the switch is so easily accessible, I may just leave it well enough alone for now and see what Lionel’s gonna do! 

Jim Z "Torn between the New York Central and todays great railroads"!

NYC Z-MAN posted:

Both of my new RS11’s lose their ID, so yesterday when I went to start my train up, no go, as they both reset to ENG 1. So, I thought I’ll just flip the PRG/RUN on each one separately and reprogram them to their original ID without shutting the power off and on. To my surprise they both responded when I ‘set’ them. I hit Train 82  and off they went! Some of you may know this already but it was a learning experience for me! Also, you need to set them up in opposite directions than you normally would to have them operate in a train correctly. These are buggy, but with this new found procedure and the fact that the switch is so easily accessible, I may just leave it well enough alone for now and see what Lionel’s gonna do! 

The RS run long hood forward normally

Carl

Arctic Railroad

Moonman posted:
NYC Z-MAN posted:

Both of my new RS11’s lose their ID, so yesterday when I went to start my train up, no go, as they both reset to ENG 1. So, I thought I’ll just flip the PRG/RUN on each one separately and reprogram them to their original ID without shutting the power off and on. To my surprise they both responded when I ‘set’ them. I hit Train 82  and off they went! Some of you may know this already but it was a learning experience for me! Also, you need to set them up in opposite directions than you normally would to have them operate in a train correctly. These are buggy, but with this new found procedure and the fact that the switch is so easily accessible, I may just leave it well enough alone for now and see what Lionel’s gonna do! 

The RS run long hood forward normally

Yes I realize this. You need to set them in opposite directions in a train, the lead locomotive has the be reversed, and the rear locomotive set as if going forward. Trust me, I have many years of understanding what goes into setting this stuff up and it is indeed backwards. I’ve set up two trains using brand new RS11’s configured in long nose forward and both exhibit the same symptom.

Jim Z "Torn between the New York Central and todays great railroads"!

Add Reply

Post
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
×