Skip to main content

Replies sorted oldest to newest

Here is the address and phone number:

Brasseur Electric Trains, 410 Court Street, Saginaw, MI 48602 • (989) 793-4753

I was just there last week. They are right downtown. Hours 10 to 5 but if you are going to go in person, call ahead. I also do a lot of rail-fanning in Saginaw. Here is the link on the OGR Forum. Lake State Railway:

https://ogrforum.ogaugerr.com/...9#167684843573344929

Gary 🚂

No other reset, you must use the reset chip for the 3-clanks of death.  It's a common issue with some early PS/1 engines.  You can also buy an updated chip for the same engine that eliminates the issue, it fixed the code that produced this issue with a dead battery.

The updated chip will only correct the locos listed on the deselect list.  It will not correct a scrambled chip due to a dead battery.  The reset chip is only used on the 3 clanks on startup.  

5CF7B555-FF4A-4465-818D-CDA3D7505EBA

Attachments

Images (1)
  • 5CF7B555-FF4A-4465-818D-CDA3D7505EBA
@Jon G posted:

The updated chip will only correct the locos listed on the deselect list.  It will not correct a scrambled chip due to a dead battery.  The reset chip is only used on the 3 clanks on startup.

Thanks, Jon, that I didn't know.  I thought the updated software would also fix this issue.  I know that the upgraded chips were claimed to prevent the three-clanks from happening, so it surprises me a bit that they don't correct it.

The deselect was a feature QSI had that allowed you to park an engine and allow it to idle in neutral, so it would be immune any commands to make it switch to forward and reverse.  There were a lot of commands available with the  QSI system that MTH did not elect to use and they were removed from the processor memory.  However, the early MTH PS1 chips  were programmed with the deselect feature, but the board didn't have the software to support it and it could be inadvertently locked in the deselect mode.  Trying to do a reset 18 (or any other reset) resulted in only getting one "clink" and the loco would be stuck in neutral. Not really sure what triggered the deselect mode in the PS1 locos, but a dead/low battery with operators pressing multiple buttons and working the throttle didn't help.  The replacement chips have the deselect feature removed from the code and chips are still available from MTH.

Add Reply

Post
This forum is sponsored by MTH Electric Trains
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×