Skip to main content

MTH responded to my question and provided a solution to the problem with the Export function in Android 10. It turns out that the app is creating a file but just no notification message when you tap the Export button.  I have attached a copy of the instructions from MTH for finding the exported file.

I followed the instructions and everything worked, but here are a couple of tips that might help:

1) When I got to step 3 (top of page 3) my phone was not visible when I tapped the menu. I solved this by tapping the menu in the upper right corner and selecting the option to "Show Internal Storage"

2) At the very end, you need to select the file by tapping on the blue folder icon. Then tap the share icon near the top of the page to attach it to an email.


I'm not sure if it's because my phone uses android 9, or if it is because I don't have a copy of the Files app.  I have a My Files app as a subcategory under the Samsung app, but no Files app.

Because of this, I don't see the same screen John shows when he says to tap the "hamburger" menu.  I don't have those three lines in the upper left of my screen.  I do have the Images, Downloads, Documents, and the other listed locations, but pixel doesn't show up on my screen.  I've activated the Export command on my Tablet while attached to the house wifi, and I made sure I turned on storage permission on both devices.  I upgraded the My Files app to release 10, still no luck.

Oh well, at least MTH got back to him and told him what was wrong.  Now they can fix the problem and hopefully make it as easy as it is for Iphone users.  At least I hope they do.  

Thanks John, sorry I couldn't make it work.  I have an old Galaxy J3 V.  My wife has a Samsung S10, but she doesn't have the Files app either.  Is it an app we can find in the Google Play store?  I'll look.


It looks like devices from different manufacturers have slightly different instructions. Here is the procedure for your phone:

1) Open the My Files app

2) Tap the "Internal Storage" folder to open it

3) Tap "Android" and then "Data"

4) Scroll down and tap "com.spindance.mthremote"

5) Tap "Cache" and then you should see the file with the export data

6) The file will have a name that begins with "wifiDcsExport-" and then a date and several other numbers

7) "long press" the file name and you should see a menu at the bottom of the page.

8) choose the share icon from this menu and you should be able to email the file to yourself

Steps 3-6 should be the same for every device. It's just the first 2 steps that might look different. I believe there are several apps for Android devices that would also work. Just go to the app store and search for "file manager".

Well, I got it.  I emailed it to me.  I finally managed to save it/download it to the phone app.  Nothing appears to have happened.  I was able to browse the switch/routes screen, but I still have the same switch setup I had before this odyssey, and none of my routes are there.  I guess at this phase of the game I need to ask the Forum as well as you, just what is Export supposed to do if it doesn't do that?  I thought once we finally figured out how to make this work, I would get the file from the Tablet, find it following the treasure map instructions we had to suffer through because we don't use Iphones, follow the instructions, save it to the phone, and everything my tablet shows me when i run trains using it, my phone would show me if i used it instead.  Based on what I am seeing without hooking it up to the WIU, I don't see that this treasure hunt has netted me anything but the same dry hole I started with.  Am I missing something?  I usually am.

Hate to be the bearer of bad news, well for me that is, I did that.  Told me the file had succeeded.  That's new.  Opened the DCS app on my phone, took a look at the routes screen, nothing, no routes.  There are 38 of the wonderful little monsters on my Tablet.  As many times as I have tapped Export over that last two weeks you'd think the cache file would have been the size of grapefruit but to my astonishment, the date on the file, if I read it right, was may 14th.  Now I can't remember what i was doing on the 14th, but if I remember my problems with Export started before the 14th, and i was still shooting at and hitting an invisible target two or three days after that.  So one would think the file date would be the most recent day i attempted an Export.  In this case it seems a random day was chosen and it stuck.  Anyway, thanks to your help and successful contact with MTH, and your patience with me, I at least have the steps and I know for a fact, they work.  I'll keep playing with it and see if there might be something i am missing that makes you say, "well duh", and this particular issue will be put to rest, at least for me it will.

The title of this post is, "MTH DCS WIFI premium APP Questions (plural) or issues (again plural), post them here.  Export, was just one of them.  Thanks again for your help and good luck with all other endeavors concerning the APP.  I like it, but boy does it have some rather unacceptable ways of doing things.  Export for Android being one of them.  

Sorry you can't get it to work. My only other suggestion is to contact MTH directly. There may be an issue that is specific to your devices.

You can get to the contact form in the app by clicking on the following menus:

1) More 

2) App settings

3) App support

At this point, a form will appear that will allow you to enter your specific information and send it to MTH. They did respond to my inquiry in 4 or 5 days.


I think you have been very helpful on this, and agree that is the best path forward, contact MTH.  I don't use routes or have an AIU, but have 3 TIU's and 3 WIU's,  DCS Wi-Fi once you get it working is absolutely fabulous.  I went from old antiquated iPad to iPad pro via the email route, it worked and from iPad pro to iPhone via airdrop.

Yardmaster, are you using the premium version or the free version?  Also have you considered the tried and true method of restarting the phone?  One last suggestion, are you using the latest version of the apps on both your devices??


The main reason I couldn't get it to work the first time I tried John's MY FILE steps is because I am a dunderhead who wasn't thinking.

Remember I said I accessed the cache and found the file and it was dated 5/14 for some strange reason?  Nothing strange about it.  I was looking at the copy of the file i had exported using the copy of the app on my cell phone.  So when I emailed the file to gmail and then updated my phone, I copied the exact file over top of itself.  It never had the routes in it to begin with.  

However, when I stopped being stupid and took my smart pill, I realized, all of the steps John sent me for MY FILES had to be done on your FROM device.  When I looked at the cache on my Tablet, it had 40 files in it, one of which was the one I exported today dated 5/21.  Realizing what I had done wrong, I proceeded with the emailing part of the process and then picked up my phone and looked at the email to myself, and there was the file.  I opened the file, up came the DCS WIFI app with a bullet statement telling me this will overwrite my file, I said ok, and success.  I checked the routes screen and there they were.

It helps to know what the H you are doing when someone is nice enough to send you the steps to follow.  Thanks to this forum i have learned a ton about how stuff works, and discovered I'm a bit of a dumba**** when it comes to following instructions.

Since we have the Export mystery solved, and I hope this doesn't get the hair up on anyone's neck, but I have about 11 more, I am going to call them "unacceptable" features of the premium APP I would like to use this post to ask about.  I won't ask about all 11 in this one setting.  By unacceptable I simply mean that even though the feature works, does what it was mapped out to do, and for the most part, warrants no repair, I'd like to find out if I am the only one who feels the way I do about the feature.

ALL switches

I spoke to Rich Foster about this one because he was the MTH person that got back to me on this question.  Why does the ALL command on the switch screen maintain control even though you have specifically selected a switch in your list after using the command?  I simply asked how do you force it to let go.  Rich wrote back and told me to just tap ALL again after using it and it lets go.  My next question was, and to the point of this post, Why?

I used the command.  I moved all 20 of my switch tracks to straight.  I then selected a specific switch to open, the green check mark was there proving I had done so.  But when I tapped the curved arrow, all 20 of my switches opened, or turned out if you like that term.  Not knowing this would happen I was startled to say the least to hear 20 switches opening at once when all I expected to hear was one switch, the one I selected.  One thing this taught me was that when ALL is selected, it maintains control.  The stupid side of me wasn't smart enough to think that if you tapped ALL again it would relinquish control, so the naive side of me kept jumping from the switch screen back to the ECS screen and back to make it let go.  Rich then tells me to just tap the ALL command again and it will let go.  Why can't it let go when I select a switch from the list?  What's wrong with it working like that?  Nothing.  In my way of thinking, any user of the APP would expect that to happen.  You select ALL, it becomes your active selection.  You select switch 3, it becomes your active selection.  Wouldn't any software program work like this.  When I use Excel, I select cell A4.  When I click someplace else, that cell becomes active.  I don't have to unclick the currently active cell to be able to click another cell.

Unacceptable simply means that if MTH has decided this is the way ALL should work, then of course I will continue to use the APP because it's all we have.  However this sets you up for the other 10 things I've used in the APP that work in an "unacceptable" manner.  Unacceptable is my professional way of not saying, "that's dumb, who creates a feature to work like that?"  My question, now that you have the details, have any of you used this feature?



I don't use the ALL function at all.  If you are finding something unacceptable, then don't use it would be my advice.  The only time I would use ALL is if I wanted to control all engines at the same speed, which I would never want, and never have.

I love the Wi-Fi app.  It allowed me to stop using the handheld and never see "engine not on track" again.  It also allows me to run all my engines on one app, pretty                                                                   seamlessly.


Didn't mean to ruffle any feathers their JB, I'll try a less harsh word, "disappointing".  I like the WIFI APP, but like, love, worship for that matter, it doesn't paint over the fact that the finished product possesses a few "disappointing" ways of doing things.  Like a Stihl weed trimmer that forces you to feed line manually rather than have what has become the standard feature of a self feeding button that you can tap against a rock and feed line quickly without having to stop.  The WIFI has these issues as well.  But I still like it, wouldn't trade it for the world, and like you I enjoy not having engine not on track showing up all the time. 

You're quite welcome sir.  I do want to ask, and this is for anyone not just JB, anyone play with Record/Playback yet?  I set up a track cleaning session and it works quite well.  Stops a bit short at the end, even when I start it on the mark.  Couple of times it has failed to stop on the mark and kept going.  But I like not having to open and close all those switches every time i clean the track.

Good to know.  Had no idea any wheel slippage was taking place, but who cares, it works and I can fudge for the lag.  I do have a question about something most of us have probably forgotten since, well at least in my case, I never could get this thing to work at all.

The microphone.  Does WIFI support this?  Correct me if I am wrong, but doesn't the TIU have a port for an outside microphone hookup?  Even so, I can't find anything in Barry's second edition guidebook that mentions use of a microphone in any capacity.  Again, I couldn't get the one on the hand held to do anything.  I saw it used in video on a dvd, but I couldn't get it to work.


The "PROTO-CAST" is supported which allows you to feed line level audio into the TIU and play it through a selected engine on the layout... the App supports this feature directly. The MIC feature from the remote was dropped from the and the "PROTO-DISPATCH" was discontinued as well. I haven't used these features much as I have found the MIC in the remote to be of poor quality and using the PROTO-CAST & DISPATCH cause considerable slow response from the remote & app when used. Your mileage may vary.

Another reason the mic was dropped was due to not being able to install 40 million little holes in every smart phone and tablet.  At least you got it work my friend.  I've always thought that MTH kind of short changed us with that feature.  If you are going to play with trains, make it even more fun by allowing us to pipe in our own cab chatter.  Get the kids, the wife, grandma, kid nap the neighbors dog, give all of them a script to read, and when you run the train, have one be the tower, one be the engineer, throw in some yard guys chiming in that this is clear or wait, we still haven't freed bob's foot from the rail.  As it circles the track throw in some idle chit chat between the engineer and the conductor.  You know, have fun with the whole family.  Or not

Add Reply

The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
Link copied to your clipboard.