Skip to main content

Hi everyone, I have the above engine and for some reason the directional lights and ditch lights won't work. I have tried turning them on via the DCS remote, but nothing. The number board lights, and cab lights work great.

I have also tried a factory reset via the remote, but it comes back onto the remote at 8 scale speed steps and I don't know if Iam doing anything wrong or not. I did have a small, short but it did not trip the breakers between the Z4000 and the TIU or the breakers on the Z4000.

Besides the lights not working the engine runs great, sounds great smokes out of this world and the cab chatter is just fine.

I am open to suggestions!

Original Post

Replies sorted oldest to newest

Mike-

Most likely the spring terminals are not making good contact with the corresponding pads. MTH uses spring terminals to eliminate the need for a harness disconnect between the shell and chassis; over time the blocks can move and lose tension, causing the lights to fail. To reset the contact blocks remove the shell and look for connectors with springs clipped to two of the shell screw posts; gently pull the connector upward (towards what is normally the bottom of the shell) to increase spring tension, then reseat the shell.

More information can be found in this forum post: https://ogrforum.ogaugerr.com/...1#161208612989823441

Hope this helps!

-John

Last edited by AcelaNYP

Hi John, just wanted to give you an update. I did something I should have done many years ago and built me a programming/test track. Put the engine on it and just used the transformer without any DCS stuff and did a factory reset. Now everything works great again!

Thanks for your help and giving me an idea for what to check!

Add Reply

Post
The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×