Skip to main content

When running the trains on my layout with an iPad (or iPhone), frequently when I sound the horn on a diesel the horn will remain on after pressing and releasing the button.  At this point, the iPad no longer has access to any of the functions including speed, hence the element of danger.  Next, I try refreshing the active engines and receive an error message, words to the effect failed to connect.  I restart the app on the iPad and receive the same error message.  Last step is to gradually reduce the track voltage.

This is a recent development.  Do I need to replace the Wi-Fi interface unit?


Tom Jasper

Original Post

Replies sorted oldest to newest

That's not normal. Sounding the horn  or any command should not cause this.

So I'd guess that you're in an area of the layout where signal is bad?

You have too much drawing power down?

or maybe your device is losing the WIFI unit and reverting to the internet?

I'd start with the last one (guess). Do you have another device to try?

Do you also have a DCS remote to test the system with?


I'm a Newbie with all this wizardry, having just made the leap to DCS in the past couple months. I've had several experiences with that exact scenario, but can attribute it to loss of wifi signal. I used to use my phone, but every time someone called or sent a text, it would screw up my MTH dashboard. Had a few close calls with that.

I have also had total loss of control of running trains, again, due to loss of wifi (in my opinion). The only cure was shut down the transformer (quickly!!!), close the app, and re-open it. When I reopened the app, it saw the engines, but in the process, the app would lose settings like speed restrictions.

Now, I only use my iPad because no one can text to it.  I have a hand-held on order that I look forward to getting. I have also had the loco stop and the horn blow, but by far the most annoying thing I experience of the random firing of couplers. Still researching that.

Another conundrum with my iPad is it is also an independent mobile hot-spot. I would expect the WIU to see it, since it's "always on" just like any other wifi,  but the MTH wiu  doesn't see it. so I just run everything runs on the house wifi.

Good luck. Hope this helps!


I only run Android. I don't know much about IOS. There was just a post last week or so, about WIFI drop outs using IOS devices.

With my Android, I tell it to forget the house router and only connect to the MTH WIFI. My devices aren't current and only are used for the trains! I get devices from my family that are about to be retired.

From reading so many IOS posts here, I'm leaning to towards there's something more with IOS devices that's in play? or is it that the devices still have service connections? (and mine are retired?)

or ....? Android using a different operating system keeps (locks on) the MTH WIFI better?

I can only guess here.

Last edited by Engineer-Joe

I believe I have solved the problem by switching from "home" to "MTH" wifi.  Today, I started the run session using the home network, and in a short period of time, the iPad lost control of the engines that were both running, ugh.  I checked the lights on the wifi unit and all the lights were illuminated, although the wifi light was blinking which I believe is normal.  After switching from "home" to "MTH" wifi mode, I had stable operation with no issues.

I believe that my home LAN network switch interrupts service to devices from time to time which may be the source of the issue I was having.  I had a similar issue with a SONOS installation and had to hire an IT specialist to fix the LAN instability problem.

Thanks for your comments on this post thread.

Tom Jasper

John, you are certainly more knowledgeable than I am about such matters and that's why I hired a very good IT guy that I have become friends with over the years.  I believe that I have a solid router, network switch and wifi access point configuration that provides stable, robust service throughout my house and backyard with the possible exception of the connection for the MTH wifi unit.  I will ask my IT guy if he has an explanation for the behavior as he can access and change the configuration settings remotely.  But, the good news is that I can run trains using the "MTH" rather than "home" setting on the MTH wifi unit and the trains obey my iPad commands.

@SirCaptain posted:

Howdy Tom, by chance is your home router a mesh wifi system like Eero, Linksys Velop, Google Wifi, etc, or is it a regular style single router access point? You mention a network switch - is this a generic 5/8/16/24/etc port network switch from a company like Netgear, Linksys, etc, or a prosumer style switch from Netgear, Ubiquiti, Luxul, Ruckus, etc?

I have the following internet equipment:

- Arris Modem from my ISP

- Araknis Router that connects to my Ubiquiti Wi-Fi system, computers and network switch

           > Ubiquiti A/P Pro that connects to slaves (?) at other locations in our house and backyard

           > Araknis 16-port network switch which services audio-video equipment

Would appreciate any insights you may have SirCaptain about the configuration that may be causing instability with my MTH Wi-Fi unit.


Tom Jasper

Last edited by Tom Jasper
@rplst8 posted:

Interesting, I’ve had similar problems with the WIU+app and I also have a UniFi Wireless access point.  Mine is a an AC Pro.

Very interesting.  My UniFi AC Pro is located about 20 feet from MTH wifi unit but the signal must pass through a wall between the interior of the house and the garage where my layout is located.  For years the system worked fine, but about 4 months ago I started to have connection problems with apple smart devices.

@Tom Jasper posted:

Very interesting.  My UniFi AC Pro is located about 20 feet from MTH wifi unit but the signal must pass through a wall between the interior of the house and the garage where my layout is located.  For years the system worked fine, but about 4 months ago I started to have connection problems with apple smart devices.

One thing you could try is switching wifi devices in your house off one by one until the problem goes away.  I’d start with the newest devices first.  If your left with just your router WIU and phone but its still not working, maybe try a new channel on the router.

Other things to try are WPA vs. WPA2, channel width (auto, 20MHz, 40MHz), and enabling/disabling 802.11b/g backward compatibility.

Add Reply

The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
Link copied to your clipboard.