Skip to main content

While running my restoration big boy 20-3807-1 (I think) my drawbar somehow fell apart. The tender and passenger cars were being pulled by the wires feeding the drawbar. I am assuming this just over time vibrated loose. When I discovered the problem the screw that holds the wireless drawbar to the loco was fully seperated from the loco. I reinstalled the screw but I believe there is supposed to be a spring and some washers. Heres a few pics. Can you pleasse tell me if there is a spring missing and maybe some washers? A few pics would be nice. I have searched the tracks looking for a spring but cant find one. I am not sure if there is supposed to be one. MTH website does not show an exploded view of this loco. I only seen a ps2 version on MTH's site, Any help is appreciated.

Attachments

Images (3)
  • DSCF4382
  • DSCF4383
  • DSCF4384
Original Post

Replies sorted oldest to newest

@kj356 posted:

Is it correct that the top of the spring and screw make an electrical ground connection from the engine to the tender so they must be touching drawbar and top of body?

Also I am having a binding problem occasionally on wide radius curves anyone else have an issue or solution? Can not figure where it is binding?

Binding can occurs if the wires to the loco side connector don’t have enough free play. Move the drawbar side to side and make sure it can swing fill width without getting tight. You may just have to try a slight tug on the connector or maybe pull the shell to provide more slack.

The spring on top of the drawbar makes that chassis to chassis connection. I believe power ground is one wire in the tether.

Pete

Last edited by Norton

Add Reply

Post
This forum is sponsored by MTH Electric Trains
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×