Skip to main content

I have an MTH Premier USRA 0-8-0 engine that has a unreliable connection through the right angle 10 pin tether that connects the tender to the engine.

The engine loses power ( no headlight or motor power) while running through curves and back to straight track. Power can be momentarily restored by jiggling the tether slightly— but does not stay on long.

I suspect a cold solder joint inside the engine.
Any other thoughts on the problem or the solution? Thank you.

Original Post

Replies sorted oldest to newest

To add to Pete’s comments, if you also suspect a cold solder joint, and you’re comfortable with close quarters combat with a soldering iron, go ahead and dress up all 10 pins on the PCB, ….reflow all of them, rather than trying to track down the one …..very common problem ….and can be addressed on your bench. Then if you’re still experiencing problems, and you know the PCB is soldered good, then suspect a bad tether,…..I’ve seen both on the same engine …


Last edited by harmonyards


Tried moving the engine socket further to rear. Not much movement if any do to bumping into inside of cab.

Pulled the tether further out of the tender to reduce strain from a short tether. Reconnected engine and tender off track to get as snug a fit as possible.

Good for now—smoke fan can turn off sporadically and be fixed by jiggling tether.

Have not tried the soldering iron yet.

Thanks for help.

Last edited by ctr

Add Reply

The DCS Forum is sponsored by

OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)

Link copied to your clipboard.