Skip to main content

Hi all,

First off, Happy New Year!  I just purchased a used Dash-8 Photo 3.0 locomotive.   When I put it on the track to get it assigned / connected, the remote says "no locomotive to add" or "check track".  I've tried moving it to different locations, powered down everything.  Any other ideas of things I could check?  Maybe something came loose in shipping? I just don't know where to start.  Thanks in advance for your help!

Last edited by Gerhardt
Original Post

Replies sorted oldest to newest

Always test in conventional to see if the engine at least runs. If it doesn't, nothing to do with DCS. So then it either goes back, or you look inside.

You could try rocking the switches for DCS and 3 rail back and forth a few times. They don't always work right.

Thanks. Ok so I fired it up on the conventional Christmas layout and it does run in conventional.  How do I locate the switches for conventional/ DCS?  I tried again on my full layout. Other locos are all running fine in DCS so I don’t think it’s a system error.

7C4E0481-D1A5-4B05-AFCA-5458B01878E5Problem solved! So I found out there is A DCS / DCC switch (perhaps what Engineer Joe was referring to above) when I was looking for any switches. It’s at the rear of locomotive under a removable cap. It was switched DCC. I Switched it to DCS and took it down to the layout and everything works as it should.

Thanks again to everyone!  Another win for the OGR Forum!


Images (1)
  • 7C4E0481-D1A5-4B05-AFCA-5458B01878E5
Last edited by Gerhardt

Add Reply

This forum is sponsored by MTH Electric Trains
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
Link copied to your clipboard.