Skip to main content

I have a pair of PS/2 3V processor boards with a symptom I haven't seen before.  I've swapped the power supply with a known good one from a working set, so I'm pretty sure this is really the processor board.

 

When I turn the board on with a TIU connected, I don't get a relay click.  However, I can add the engine and start it up under DCS control.  However, I can only go forward, even though the board thinks it's going in reverse, the motor is still going the same direction.  Another issue is that when they came in, the audio amp was toasted, I've removed the old one so it won't affect the operation.  I didn't feel like putting one on unless I could figure out why the relays don't pick.  The only diagnostic help in the ASC manual is to "check K1 for proper operation".  Well, it's not operating, that much I know.  The other suggestion is a replacement on the power board, clearly that isn't my issue, when I move the power supply to a good processor board, everything works fine.

 

Any idea which component to look at next?

Original Post

Replies sorted oldest to newest

So the direction relay is not clicking into reverse.  I'd measure coil resistance across the 2 big pads on left.  Per datasheet for the 845N-2C-S 5V, it's about 50 ohms.

 ogr ps2-3v relay drive

 

If that checks out, by inspection you can see the 5630 SOT-23 N-FET driving the relay.  Does this pin get pulled down (one side of relay coil tied to +5V as indicated) when commanded into reverse?  If not, then maybe the N-FET is toast (FDN5630).  Of course the N-FET gate pin as indicated is high when the relay is driven.  If this pin does not go high then that's a digital signal from the processor electronics at which point all I can say is good-luck!

 

Attachments

Images (1)
  • ogr ps2-3v relay drive
Last edited by stan2004

I had checked the relay after the last post, and indeed it measures around 48 ohms.  The contacts are also in the correct position for a non-energized relay, so that eliminates the contacts welding and holding it on.

 

If the FET isn't bad, as you say, the boards are likely toast!  I'm going to put them back on the tester to see if the FET is working and hope that's what has happened to them.  I hate to tell the poor guy that both boards are bad.

 

Are all the lights, LED, Smoke and Couplers functional?  Or are some out?

 

I don't understand your comment about goes fwd but thinks it is in reverse?  Have you tested in conventional and DCS, or DCS only? 

 

As far as stuck contacts, that is still on the table.  The relay normal unpowered condition is set for FWD motion.  Which is what you have.

 

Power up and carefully jump the FET for relay.  If the relay switches, you can change the FET.  If that doesn't solve it look for a burned trace and work your way back to the FET gate signal via the buffer.  You can change the buffer.  If not that, the processor segment is bad and the processor board needs to be replaced.

 

Interesting that one owner has two boards with this symptom.  I don't see many failures like that.  Was speed control ok on the power supplies?  They normally go when the audio amp does, especially other things go wrong on the processor board.   G

Last edited by GGG

George, yes all the lights and smoke are functional.  Of the power supply boards, one had the op-amp dead, that brought that one back to life. , the other P/S board was toasted, Q22 had literally melted down and destroyed the traces in that area, almost burning through the board, so that one is gone.  The speed control could be bad on that one as well, I'll never know and it didn't do anything on the boards when I got it.  Q22 is also an obsolete part that I couldn't find a cross reference for, even if it hadn't cooked the board.

 

I found it odd that both processors had the identical failure, but I'm thinking that maybe he swapped things around and the failure affected both boards.  Q22 was curious on the one P/S board, that being associated with the battery circuit.  Perhaps that was a different failure cause.  Truthfully, when the relay doesn't operate, usually the board doesn't respond as well, at least in my experience.

 

The relays are good, I tested it with an external supply and the contacts switch as they should with the relay energized.  I don't see any cooked traces anywhere visible, though it appears some of them would be under the relay.

 

The "thinks it's in reverse" was referring to the fact that the motor always runs forward, even though the lights say I'm in reverse.  Obviously, the relay not operating is why that's happening.

 

What buffer connects to that FET?  I don't see a buffer in that area of the board, is it one of the '244 chips at the other end?  I was thinking they might be driving it direct from the processor.

Wow on Q-22.  They can handle high amps.  Was Q-23 or r36 toast too?  Maybe he plugged a battery in wrong.

 

Trace may be internal, yes buffer controls FET for K-1, but with everything else working it is either an isolated issue with that segment, or the processor feed.

 

I have a few boards with motor related issues and usually it traces back to the processor not working right.  Wish that was a larger 8 leg chip. G

Don't know what happened to Q22, it's the first time I ever saw one smoked like that.  I had a bad feeling when I saw all the burn marks around it, when I picked it up, I just had to desolder the inside pad that provides heatsinking, the whole outside set of PCB traces were toasted and gone!  A reversed battery could explain it I suppose, you can get a lot of current from those.  I wrote that board off as a loss.

 

Which of the '244 chips is the one that is connected to that FET for the relay control?  It'll be a bummer if the processors are gone.

 

I scoped a working board.  When in reverse I get a 5V PWM signal on the 5630 gate; when in fwd the signal is low.  This signal also appears at pin 7 of the 244 buffer.  For a 244, the corresponding input is pin 13.  That signal has a smaller 3V PWM signal so the 244 is boosting/buffering this to 5V pulses.

 

So if you have nothing on pin 13 when in reverse (and you know the processor "thinks" it's in reverse by the backup light or some other non-relay reverse indication), then it doesn't look good

 

I agree it's curious that you have 2 boards doing the same thing.  Makes you wonder if there's someone out there who has an engine that ONLY needs to go in forward such as some kind of window display or whatever!

I discovered, I was indeed looking at the wrong pins.  I do have a signal on pin 13 of the '244, and nothing on the output, pin (7) even without the FET in the board.

 

Both of them do the same thing, so I have to get the part.  They're labeled HT244, so I'm wondering exactly what they are.  You don't happen to have an actual part number for them, do you?

 

There is a difference in the two boards.  The second board works exactly the same way except when I turn on the smoke, it shuts down the board.  However, if I don't turn on the smoke, it's identical operation.

 

I'm thinking whatever happened to the P/S that has the cooked FET may have damaged the same component on these boards.  As George says, it could have been a reversed battery, that FET was really smoked!

You're right Stan, I was thinking that replacing that was the first step.  I'm surprised that all the other functions work, and even smoke on the one board.

 

One wonders exactly what happened to these, I'm going to have to press the guy on what he did.

 

I'm old, so those gray cells are dying.  Thanks for the thread reference, I thought we had talked about the 244 before.

 

 

Last edited by gunrunnerjohn
Originally Posted by gunrunnerjohn:

One wonders exactly what happened to these, I'm going to have to press the guy on what he did.   

I created this problem just the other day by accidentally shorting the heating elements to the metal in the smoke unit in a slave B-Unit after changing the wick.  After some fascinating blue sparks (from the 18V AC common to the heating element), the engine:

1) doesn't click the relay when applying power.

2) doesn't click the relay when switching forward and reverse.

3) doesn't have sound.

4) only goes forward very fast when rolling the speed from 0 to anything.

5) it will stop when rolling the speed to zero.

6) lights do work, but I didn't pay attention to changes with direction.

7) didn't try in conventional, or try turning the smoke units on/off.

 

Something definitely got burnt because I could smell it from the board, but I can't see anything that looks burnt.

 

I changed out the Ps2 boards today and tried it with the unchanged slave unit, and everything worked fine.  I feel a tiny bit lucky that the slave board is fine since it's much more annoying to find.

 

I'll be watching this thread to get ideas on salvaging something from my slightly toasted boards.  Is there any wiring diagrams or other troubleshooting documentation available for Ps2 boards?

 

Eric

Last edited by Eric Linz

Eric,  No diagrams, all learned by reverse engineering and trial and error. MTH documents only go so far on audio amp, speed, control and basic light FETs. Most likely you have damage to both the top and bottom boards.  Your symptoms are quite different.

 

Anytime AC gets on the board DC side, it causes lots of damage.   G

Last edited by GGG
Originally Posted by Eric Linz:
Something definitely got burnt because I could smell it from the board, but I can't see anything that looks burnt.

Just curious, did you happen to separate the board pair and localize the aroma - power-supply or processor, top, bottom, left, right, etc.?

 

Since you say everything works with a known-good board set, that suggests your problem(s) are on the boards.  Suggested shopping list for a DigiKey order:

 

1,2:  replace U8 on Processor board (74HCT244PW) - buffer

        (and 0402 10K resistor unless you can salvage existing part)

3:     replace U5 on Processor board (TPA2000D1PW) - audio amp

4,5:  replace U12 on Power Supply board (LMV358M) - speed control op amp

 

I'd say the best troubleshooting info for DIY is right here on OGR.  There is some kind of troubleshooting test-fixture that MTH provides to work on boards on the bench.  Perhaps someone could post a photo of what that is but I think you need to be an authorized service center or whatever to get one; I'd think any MTH documentation would be based on using that test-fixture.

 

Last edited by stan2004

The test set is indeed available to ASC Certified Techs, here's what it looks like.  I've added a couple of features, a 2A circuit breaker and the 5V regulator so I don't have to have one hanging in the breeze when testing 5V boards.

 

It's good for both 3V and 5V PS/2 and LocoSound boards.

 

 

MTH PS2 Test Set

Attachments

Images (1)
  • MTH PS2 Test Set
Last edited by gunrunnerjohn

There's a completely different test set for PS/3, and it was twice the price!  It comes with a whole forest of cables that you can test all the various combinations of PS3 boards for HO, O, and G boards for diesel and steamers.  The cables laying by it are only the O-gauge steamer cables, there's about 15 more sets in the box.

 

 

 

 

MTH PS3 Test Set

Attachments

Images (1)
  • MTH PS3 Test Set
Last edited by gunrunnerjohn

The test set just replaces the engine hardware with know good wiring, motor, smoke and lights/couplers.  It is useful in seeing what features work or don't easily.

 

The PS-3 also comes with some "Golden" Boards for testing.  Remember that PS-3 Steam is a two board set, so you need the other board to test a suspect bad Boiler board as an example.  G

@Dansgnrr posted:

Gunner got a smoke detector off a PS3/2 board that will not run off the Test fixture. Do I need to connect A PV wire to one of the pins as it only has 3?    Otherwise the board under test will run.

I have no idea exactly what you mean.  3-Pins?  Smoke detector?

Can you clarify exactly what you're asking?  if you have the PS/2 test fixture, you don't need any extra wires to plug it in and test it.

Add Reply

Post
The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×