Skip to main content

I stuffed some PS3 guts from a cheap RTR 2-8-0 into a nice premier 2-8-0 recently.

The RTR loco didn't have an interior light, firebox light, or marker lights. I installed those in the new engine and connected them to the appropriate outputs. I loaded a good Premier sound file into the engine, and flashed the appropriate chain file (in that order).

Everything seems to work great, with one small exception. When the engine first sees power, everything powers up as expected (before pressing 'startup' on the remote). Markers, headlight, smoke, firebox glows with a flicker, and interior light illuminated.

But as soon as I press 'startup', the firebox switches off and cannot be toggled back on at all, even though the remote says it is. All other lights behave as the remote commands, and I can toggle the markers, headlight and interior light on and off using the appropriate soft key on the remote. But not the firebox. The soft key is present, and shows cycling on and off when the button is pressed, but no reaction in the loco.

If I cycle power, the firebox comes back on and flickers away until I press 'startup' again and it disappears.

Do I need to reload the chain file? There were a couple errors during loading where the loader software said 'retrying at a slower bit rate' and then seemed to be successful and moved on to the next sector. But other than that I saw no other errors after flashing the chain file.

The loco board was not the relay version board, and I think I selected the right chain file for the non-relay version of the loco board.

Thanks



Jeff

Original Post

Replies sorted oldest to newest

@John H. I got some guidance from some forum members regarding where to hook up the lights!

The boiler board had all the outputs and like I mentioned the lights all work, and I know the firebox is in the right output because before startup it actually 'flickers ' which is I assume controlled by a variable current that's directed by the software. I'm thinking I'll need to reload the chain file.

I have never seen this behavior.  When you power up the track with DCS watchdog present, nothing lights up.  Not until startup pressed.

In conventional only HL and possible Tender light will come on until supercap charges and the board starts up.

I would start with a reflash, followed by sound file if the reflash doesn't work.  G

So I was getting ready to reload the sound file, but on a whim I tried the 'feature reset' first. I already tried the factory reset without luck, but wouldn't you know it, 'feature reset' and a power cycle did the trick!

All put together now and features all active. Only thing is...

I think I need to insert a spacer in the worm to prevent it from pulling backwards (due to end play in its mount) when the engine is in reverse. Forward direction everything is smooth as butter down to 3smph. But in reverse, at low speeds there's a tendency for it to bind and stutter a lot. I think it's pulling the shaft and coupling and closing that gap between the motor and worm, squeezing the dog bone and creating lots of friction.

Thought I was done...

Video makes the lights look like they're flashing, not I think that's just a frame rate things on my phone. Headlight and class lights look steady on in real life.

Attachments

Videos (1)
20240329_135525

Add Reply

Post
The DCS Forum is sponsored by

OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)
www.ogaugerr.com

×
×
×
×
Link copied to your clipboard.
×
×