Skip to main content

I purchased the RR-Track Lionel Fast Track examples pack and am trying to recreate the "Cozy Confines" 12X10 layout in AnyRail and some of the pieces are way off from RR Track. Also, is there a way to remove the trees and structures so I can see the track labels more easily in RR Track? I'm thinking because Cozy Confines is a pre-packaged layout maybe I cannot remove layout details from the view. Any help or guidance would be appreciated. 

Attachments

Files (2)
AnyRail Version
RR-Track Version-Can't See all Track
Original Post

Replies sorted oldest to newest

Thank you @DoubleDAZ that helped me see the track sections which I added to AnyRail but there are four points on the layout (new file attached) where it doesn't really fit. AnyRail has part# 6-12073 as 1 1/4" but I believe the actual part is 1 3/8" which is reflected correctly in RR-Track. There are numerous pieces of this part which could be throwing off the AnyRail connection points. Has anyone experienced this? Is RR-Track more accurate the AnyRail? I would like to build this layout but want to have confidence all the pieces will fit before spending the money on all the track. Any advice/insight would be appreciated.

Attachments

Files (2)
AnyRail file with 4 connection points not fitting
RR Track Version

I’m not that familiar with AnyRail, but in settings, my version says the tolerance distance is 0 and the tolerance angle is 3. In RR-Track, the Join Error is set to .05” and I don’t know of a setting for the angle.

However, SCARM and RR-Track both say the track is 1 3/8” while the Details display in my version of AnyRail says 1” and that would definitely throw things off. FWIW, it also says #6-12074 is 2”. If you change the track display setting to show Description instead of Part Number you can see the lengths and they are definitely wrong. If you place the track in the upper left of the work space and zoom in, you’ll see that also says 1” based on the ruler coordinates of 0,1.

I just checked the Atlas library and AnyRail says #6052 is 2” when it’s actually 1 3/4”. I’m surprised no one has pointed that out and it might explain why I’ve seen some AnyRail users say things don’t fit when laying track. Hopefully, I’m missing something because there are a lot of designs posted here and published in OGR using AnyRail.

Last edited by DoubleDAZ

People who use software to help design trackplans for others don't usually try to recreate those plans in a different software product.  They just manipulate the "digital" pieces in the software being used until a plan comes together, assuming that the pieces will match reality when built.  Your effort here may have identified some differences between "digital" pieces in AnyRail and "real" pieces of produced track.  Until this is resolved, I will stop recommending AnyRail to people looking for design help.  Thank you to @Fireball RR and @DoubleDAZ.

Chuck

The only thing wrong in Anyrail is the description, someone mistakenly called that filler as a 1 1/4" instead of the correct 1 3/8.  When you actually measure the piece on a layout plan, it's the proper 1 3/8" in size.

Since it's difficult to get the ruler tool to measure that small, I put four of them together, they come out to exactly 5.5".  Divide that by four and it's 1.375" for each piece.

I found Anyrail very good for Fastrack when I was using Fastrack.  If it said it wasn't going to match up, it didn't.  If it said it was going to mate up, it did.

Truthfully, I'd take Anyrail over RR-Track any day of the week.  I still have a copy of RR-Track that lives in a drawer around here somewhere, I've long since uninstalled it in favor of Anyrail.  RR-Track is way harder to use than Anyrail.

Attachments

Images (1)
  • mceclip0
Last edited by gunrunnerjohn

Good to hear, John.

FWIW, I found the problem. In the Settings menu, the left most Units options control what is displayed. The defaults appear to be English Decimal Units with 0, 1, 2 and 3 options. The default is 0, so the display is rounded to the nearest whole number, which is 1”. If you change it to 1, you get 1.4”, 2 you get 1.39” and 3 you get 1.386”. However, if you change the option to English Fractional Units, you get 1/4, 1/8, 1/16, 1/32 and 1/64 options. With 1/4, it rounds to the nearest 1/4”, so you see 1 1/4”. It needs to be set to 1/8, so you get the nearest 1/8 and see 1 3/8”.

Unfortunately, this doesn’t explain why the design doesn’t join in AnyRail, so maybe it’s the default join error differences.

DD414BEB-F70F-454E-A9DF-14624E275CA862909217-986C-4EED-BA3E-F0BAD005A42C1D72600D-43B2-4820-8C3C-51A66127CC85

Attachments

Images (3)
  • DD414BEB-F70F-454E-A9DF-14624E275CA8
  • 62909217-986C-4EED-BA3E-F0BAD005A42C
  • 1D72600D-43B2-4820-8C3C-51A66127CC85
Last edited by DoubleDAZ

@CAPPilot Great question. I have unfortunately used software in the past to create a layout, went out and bought all the pieces and then it didn't fit so I'm very gun shy at this point. In this case it looks like it has happened again. I'm going to play around with it in AnyRail today to try to match it up to an acceptable tolerance but I'm bummed that I might not be able to create this layout on my own.

@Fireball RR posted:

I'm going to play around with it in AnyRail today to try to match it up to an acceptable tolerance but I'm bummed that I might not be able to create this layout on my own.

It was my experience with Fastrack that when you got close, you could tinker with the small pieces and fine tune for a proper match.  It is important that you not try to "bend" a connection to fit, if they don't fit flush, they can quickly cause connection issues.

You can also post your "final" Anyrail file and maybe one of us can figure out how to make it fit.

Last edited by gunrunnerjohn

RR-Track will allow you to connect "imaged" track perfectly AND "sort-of" .

RR-Track's elements are imaged precisely.

When you assemble the actual track there are a number of variables in the actual layout that NO program can recreate, such as surface flatness, slopes and other track-connection irregularities.

These differences may seem slight, but they can add up over the totality of a layout.

RR-track tries to compensate for the irregularities that arise by allowing a tolerance of connections that you can control under various options.

The real question is, does it connect in real life?

My guess is it all depends on how it’s installed. If it’s all dry fit before being fastened to the decking, I suspect it will fit. If you draw the design on the decking and follow it while fastening in sections, I suspect it will fit. However, if you fasten while assembling, I suspect it might not fit for the reasons mentioned. I’m surprised though that it all connects in RRT when it doesn’t connect in either SCARM or AnyRail.

Alan, they all have settings for how OFF the tracks can be and still connect. From what I can tell, RRT allows .00”, .01”, .02”, .05”, .10” and .20”, but I couldn’t find any angle setting. AnyRail offers a bunch of options, but appears to max out at .787” and 3°. SCARM allows up to .591” and 7.5°, but defaults to .079” and 2°.

In the case of SCARM, the tracks seem to be off by about 1/2”, but they also overlap. SCARM won’t join them when they overlap, but if I move one track down and keep it 1/2” off center, SCARM will joint them if I change the tolerance to .591”. It doesn’t actually move the track, it just removes the arrows signaling a disconnect and when you double-click, it selects the adjoining tracks. I’ve tried everything I know to try to figure out what’s causing the differences and I’ve come up with nothing. FWIW, closeups show where tracks in RRT don’t join exactly, but even with the tolerance set to 0”, the tracks still join.

I have a question about AnyRail. When I look at the track library for FasTrack, I see switches that need fitters are there in sets. When I select it, I get a switch and 1-3 fitter pieces. In the case of O-60>switches, I select the half-roadbed pieces for the 2 sections past the frog and then delete the piece with no roadbed. Is that the correct/only way to select the switches that need those fitter pieces? In RRT, the fitters are labeled 12000x and in SCARM they’re labeled with half roadbed and no roadbed. AnyRail also lists the fitters separately in the library, but not the switch itself. Am I missing something?

Working in AnyRail takes a bit of getting used to for any of the track libraries that are used. I worked on mine with Ross track on quite a few different designs. One thing I've learned which John had said above is about measuring pieces. All the tracks have the lengths on them so it is just a question of making equal lengths to fit wherever you are working on. Sometimes you may have to dismantle longer sections and piecemeal a bunch of smaller sections to get whatever distance you need to cover. I think one of the ones I had to do was make somewhere around 15-18 inches in what I had to do. Originally started with longer pieces or a combination of, but wound up using the smallest pieces fit together to make it connect.

Since my layout was build with a lot of flex track, I just positioned the switches and fixed track features as close as I could verify on my plan.  Then I'd just take a piece of flex and stretch it to the destination.  One trick I found useful was to forget about the actual size of the flex and just connect a piece between the two points and then use the "smooth flex" feature to clean up the curves.  That oversized piece of flex might actually end up being two pieces, but the object of the exercise was to get a smooth curve between the two points.

Not really, I just delete the fitter pieces after dragging the switch over.  I just figured that was "the way it worked".

Thanks, just didn’t want to miss something. Unlike SCARM, that’s at least a way to remember those fitters are needed and SCARM users are prone to forget. RRT won’t let you connect anything but a fitter. Of course, during the build you can connect any track as long as you trim the roadbed first.

Add Reply

Post
The Track Planning and Layout Design Forum is sponsored by

AN OGR FORUM CHARTER SPONSOR
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×