Last week I had connected my TIU up and did the latest firmware upgrade. This week I hooked it up to my PC to update the firmware in the remote but the DCS loader 5.0 could not find the TIU. The PC could see the serial to USB device but the loader couldn't find the TIU. There is power in the TIU as the red light is on so I am not sure what is going on. I had used this setup several other times. Is it possible that the serial cable could go bad or is this a sign of the TIU going bad? Any help would be appreciated. I don't know what revision my TIU is but it says DCS on it instead of Protosound 2.

Original Post

well before you start the dcs loader to transfer update you want to do a search for port first sometimes the loader can't find the port on your computer, but if you do a search first and the port  comes back with tiu port  5 found for example. then start your loader and see if your remote updates remember you have to hold in the power button while remote is updating!

o gauge  trains ,music ,computer repair windows 7 and 10!

ASC Tech MTH school completed! 2019 !

I tried several times and to the letter. I have connected to the TIU without trouble but this time it just cannot find the TIU. Mine is usually on port 3  and I have tried everything but no dice. The last time I had this problem it was the cable. The cable I tried last night is only a couple of months old and never gave any problems until last night. The PC I have is for the TIU only so it doesn't get used for anything else. I have tried everything possible here so I am guessing a new cable may be next and then a new TIU after that.

Just yesterday I had a bad USB cable. Trying to update a Rev L TIU using USB and the DCS loader would not find the TIU no matter what. I tried everything possible and it still couldn't fine the TIU. Finally dug out a different USB cable and swapped them out. The DCS Loader took right off finding the TIU immediately! It then updated the TIU and Remote without any further problems.

That's the first bad USB cable I have ever experienced, but it sure seemed to be the problem. I didn't bother checking the cable, just dropped it in the nearest trash can.

I have quite a few USB cables just laying around here doing nothing so it was an easy swap for me. 

When I started out yesterday, I just grabbed a random USB cable with the correct ends to fit a TIU for updating, so it's status was unknown. 

I also reread the thread and see you have a USB to Serial cable, mine is just a straight USB connection to a Rev L TIU. I suppose the Serial to USB cables can go bad as well?  

What's odd about yours is that it just worked last week with your TIU and doesn't work this week? That kind of makes me wonder if the cable is really the problem? Did you try another USB port on your PC and tell the Loader to Search for the TIU? If not I would try that first, before buying another cable. 

Hopefully you'll get lucky like I did. Sure hope you don't have a hardware problem that requires your TIU to be sent out  somewhere for repair.  

I got another cable from a friend and I will give it a try. I got a cable with a different chipset. I didn't know it but they have a chip in the cable I guess that does the adapting. The last two cables I had that took a dump were prolific chipsets and stubborn to get installed. I am hoping with all appendages crossed that it does. Although I did find a guy who can fix it if needed for a little money. 

I can definitely say that the Serial to USB Lionel recommends for Legacy updates did not work with my DCS system. However, it works perfectly with my Legacy system, no problems at all. So I agree that these cables are not all created equal. 

Good you have a repair person to fall back on too.

I know of Ray's Trains. Gardner, KS is just a few miles SouthWest of me. Never been to his place as I'm not sure he has a retail store? He has a good reputation though and is good with DCS. I believe he participates here on the forum too. I've watched some of his videos about DCS and his website has a lot of good DCS info. 

I never heard of Ray, I found him on a Google search.  I found out that my cable had not a problem but there is actually an error in the on screen instructions. When programming the remote you have to apply power last which is kind of hard while holding down the on/off button. I bought a new cable anyways as i learned that the Prolific chip set gives me a hard tim on all my PCs. I will be sending my broken TIU to Ray next week as he assures me that he can fix it. I will get a revision L one of these days but no time soon.

There's a post in this very recent thread: Current experience updating TIU and remote software: much less hard than years ago. Post is by Ron045, he includes a link to some drivers that might help with DCS upgrades. I believe they may help with the 'prolific chip set', FTDI drivers or something like that.

I remember reading about this back when Win 10 came out. I did look for it on MTH's DCS download page but didn't see it. Of course, I wasn't looking in the correct place for it... Thinking the problem may have been resolved because it wasn't in the downloads area, I just went ahead with the upgrade.

I think Ray's will give you a good repair. I've heard good things about his services and DCS knowledge. Need to remember that place myself. I could just drop things off to him, and pick them up. About 20 minutes away. No shipping involved! 

Hi   Just a quick clarification, I can repair TIUs but with TIUs can never be sure 100% of the time (all depends on what the issue is).  I try to get as much information ahead of time to try and determine if I think something can't be repaired to save on the cost and hassle of shipping back and forth.  Engines are a different story, I do stock plenty of electronics etc to handle just about anything that comes my way and do try to get repairs done in a couple of days (sometimes may take a few days depending).  If ever have questions shoot me an email.  

Add Reply

Likes (1)
Post
The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
×