Skip to main content

I am having a problem with my TIU. The Variable port 2 has 25 volts DC on the output... I have the port programmed to the fixed mode and am applying 19 volts AC on the input side. All of the other channels are working correctly. It is a fairly new unit and is a Version L with 6.1 software. Thanks for any help

Original Post

Replies sorted oldest to newest

Everything in phase?

If it were me, and going on your description, I would first disconnect all TIU outputs to eliminate any downstream wiring issues. If the problem goes away you know where to look.

If you still see the high voltage, disconnect all other power sources and leave only the source feeding port 2. If you don't use aux power to power the TIU obviously you need to have fixed one powered, just leave all TIU outputs disconnected to the track. See if you still see the high voltage on output 2.

Its definitely the FET as John says   Very common problem on Rev L   Always the variable voltage port   You have the high voltage when measuring but the symptom is more complex   When you apply a load, the voltage will go down to between 0-8 volts  We had one that displayed 45 volts with no load and went to 12 volts with a load   

Its fixable if you are a pretty good solderer    Otherwise a service tech can do it

We also have been having failures in the variable channels, but ours run up to 8 hours a day every day, so they get a lot of use and voltage run through them.

One problem we do have, when set to fixed, often they revert to variable on their own, which can be frustrating, explaining to those running to check if it has gone back to variable, and walking them through a reset to fixed. Do that 5 times (5 TIU's in super TIU) and it takes a bit.

Ron, since the variable ports will automagically switch back to variable if you select the TR and change the voltage, it can be done by anyone with a remote.

You can also just cycle power to the TIU channel and it'll go back to fixed (until the next time).

It does seem that the Rev. L TIU's have had more specific issues with the variable channel FET's as well as much more frequently eating their 74ACT244 DCS signal drivers.

Add Reply

Post
The DCS Forum is sponsored by
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×