Skip to main content

Trying to upgrade the software on a TUI Rev L from 4.10 to 6.10 to connect WIFI interface unit. Installed the Consumer Downloader V5 and 6.10 software files. Installed the jumpers and connected a USB cable and the program could not find the TUI. Try a USB to RS232 cable with a power brick and had the same issue (Note this PC is running windows 11). Tried both cables on an older PC running windows 10 and got the same results. Any assistance would be greatly appreciated.

Original Post

Replies sorted oldest to newest

So if you are using a serial cable- you have to separately power the TIU as indicated by the red LED power and status light. I typically use a 12V adapter plugged into the aux power in port.

Part2- regardless of direct USB or USB to serial- your computer must have enumerated the software driver for a virtual serial port.

The 4 conditions must be met:

#1 the TIU logic must be powered

#2 the audio jack cabled plugged into the 2 ports is what puts the TIU in bootloader mode to accept the firmware.

#3 Your computer must load a USB to serial driver to make this virtual serial port. When using direct USB cable on a Revision L TIU, that chip is a FTDI USB to serial inside the TIU, but again your computer must load the driver and enable that port. If using an external USB to serial port adapter- then the driver for that cable must successfully load into the computer and enable this virtual serial port.

#4 No other serial port communications software can grab this serial port- preventing the loader software from also accessing the port.

Last edited by Vernon Barry

Thanks Veron... I am using a separate power supply with the USB to serial cable and no other serial port communications are accessing the port. Tried another USB to serial cable (VANTEC) which was mentioned on the forum that worked. Loaded the driver and I am still having the same issue. I have read in the forum that MTH had a driver but I can find it on the MTH web site. Does anyone have this driver they can share?

In additional to Vernon's comment "#2 the audio jack cabled plugged into the 2 ports is what puts the TIU in bootloader mode to accept the firmware."
When you power the on the TIU the red LED should not blink at all during the power up. If it blinks you may have a bad Audio jumper cable. The light should remain lit during the entire process.

The driver for the USB port of the TIU is a generic FTDI driver. Windows 10 & 11 have the driver built in and there should be no need to download it from anyone.

Knowing exactly which "COM" port the TIU is connected to greatly helps because then you specify that COM port (vs. Auto Detect) to communicate to the TIU.

Here is a comprehensive YouTube video of the upgrade process: Updating the TIU Firmware

Last edited by H1000

The TUI red led is not blinking on power up and I have tried two different audio jumper cables.

When you first power on, with audio cable, it should power on and blink once indicating the TIU number and then stay on solid. I just tried mine, from power on to the blink on mine is about 4 seconds. Again, once it boots past this in normal mode, the LED is just constant on.

With the audio cable plugged into both jacks, and then power the TIU, the LED is just constant on and never blinks.

So net effect, the LED is not a great indicator of mode and certainly not a good telltale if bootloader mode is enabled.

The LED by the Remote Input stays solid but there is another red LED towards the center of the TUI that blinks once when powered up. The remote is set to TUI 1 and both the remote and TUI are at software version 4.10. I have no problems running a train from the remote.

Well, if you tested the serial cable and now know it was good (passed the loopback test) that proves the driver for that cable is working, the cable is working and applications on our PC can send and receive serial data.

I would try again using the consumer loader application, ensure the tiu has power and the red power/status LED is on, and the audio cable is connected and see if you can now update it.

That second LED near the radio board only flashes for a moment normally on powerup and thus why nobody mentioned it previously. It's when that tiny LED stays on, then that's a really bad situation the TIU is not booting, and might be bricked- I have one in this condition.

Last edited by Vernon Barry

Hi maybe you need mth driver code for usb driver for your computer to connect to tiu!

also the remote id is 0 which is for tiu 1 id 1 would be for tiu 2 !

check remote address setting since your tiu led is flashing ounce that's good!



Files (1)
1driver for your computer for usb port to work
Last edited by Alan Mancus

Thanks for the driver Alan. Unfortunately I still cannot connect to the TUI. Looks like I have run out of options so I am shipping the unit Mr. Muffins Trains who said they would upgrade it at no charge, I just have to pay the shipping. Thanks everyone for your help. On the plus side, I did learn a lot from this experience. 

Add Reply

The DCS Forum is sponsored by

OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)

Link copied to your clipboard.