Skip to main content

I am having deja-vu of days when I had so many problems with new engine purchases circa 2000 to 2007...fast forward to 2016 - brand new Premier T1 with PS3.0 (my 2nd 3.0 engine) continued to come up in conventional mode (on FXD1 and FXD2) tracks - after about 10-15 seconds after powering up track - although tender light came on right-away upon powering? BTW: I set Z-4000 to 15-16 volts for command. I could not get it to "add" to DCS remote - "no engine to add." Finally, got it to add but basic command operations were slow and erratic. Tried both factory and feature resets - no help. Deleted engine from remote - and tried PS2.0 and my one other PS3.0 engines - they all worked fine - so DCS is good to go (software version 4. something).

Tried T1 again - this time it added to remote on first try - seemed to run well but then headlight and backup light both went out. Switches on engine are correctly.

Instruction manual basically has nothing about running under DCS - 98% is about conventional instructions.

Is there a certain voltage PS3.0 engines need to run in command? Is 15-16 volts enough - or should I try 20 volts?

Does this engine's behavior sound like something you've encountered? Will it have to go in for repairs?

 

 

Last edited by Paul Kallus
Original Post

Replies sorted oldest to newest

Barry - the switch is on the bottom of the tender - I tried moving to DCC and the engine's headlight and backup light came up as soon as track power was applied - then it came up in conventional again. I turned it off and let it sit a minute - moved the switch back to DCS - and it again came up in conventional. I did another factory reset - the engine added (on the 4th try) and I ran it for about 5 minutes but eventually lost control via DCS handheld - and had to shut down handle of Z-4000 to stop the train. When it was running it ran well - speed control worked as did whistle and coupler, but PFA never worked, and eventually it became very erratic.

I guess I'll have to call MTH on Monday, unless there's something else I can try? Or, I might send it back to the dealer that sold me it, admittingly I am kind of getting fed-up with defective trains that cost so much, and I've only been back in the hobby a short while.

Thanks.

Last edited by Paul Kallus

Paul, When added, do a DCS signal strength test on that engine.  What does it read?  Do it when moving to.  If not 10s I think there could be issue with blackened ground screws for AC Ground input.

Also, the tender light should not be coming on when power applied in conventional.  Normally just the Headlight.  So I am not sure what is going on, and a call to MTH Tech support may help.   G

Add Reply

Post
The DCS Forum is sponsored by

OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)
www.ogaugerr.com

×
×
×
×
Link copied to your clipboard.
×
×