Skip to main content

Have over 50 Z-stuff switch motors on the layout.  All work fine ... except the latest one.  Wired it just like the others that do not use a relay.  Everything works; right/left throws, non-derailing, lights on controller work ... BUT the lights on the switch motor stay dark UNLESS the wheelset of a car is sitting ON the non-derailing isolated rail piece, then the correct light will light and stay on as long as the wheelset is sitting on the isolated rail.  It throws the switch correctly to re-align it, but the lights just won't work as advertised.  Switched the LEDS around, re-oriented them (flat side thing for polarity), replaced them, replaced the controller, switched the controller lights back and forth,  still no lights on the switch motor.  One other strange thing; the controller works opposite of MOST of the others ... right button activates left light, and vice versa.  And the wire is a different color on one of the posts on the controller.  White instead of green for "R".

Thought it might be like one other button I had a problem with; the "R" wire really went to "L" inside the controller; worked opposite of what one would think.

Have now spent 7 hours on it over 3 different days on this cursed switch/controller.

Ready to just have one non-lighted switch on the layout ... no idea what to try to fix it having exhausted the above diagnosis process.

Any idea what I'm screwing up to make this happen and how to fix it so it works like the rest of them?

Thank you!!

Original Post

Replies sorted oldest to newest

Have you sent an email to Dennis Zander (Z-stuff) regarding your problem?

He's very responsive and helpful.

My last 'problem' with Z-stuff DZ1000 switch machines is almost too embarrassing to talk about.  Suffice it to say, I had tapped into the wrong bus wire.....thinking I was getting a 14v signal....only to find that I had only 6 volts to the four machines of the double crossover.  Well, duh!  Which then enabled me to say that I have never had any problems with Z-stuff items....switch machines, relays, block signals, semaphores, wig-wag crossing bucks, et al....except those of my own stupidity doing.

Try Dennis.

KD

Last edited by dkdkrd
phil gresho posted:

I second the motion to call Dennis.  He'd probably agree to swapping it for another;  then he'd maybe fix it on his own time.

Think it's the switch motor itself?  Swapped in a new controller and it didn't change or fix the problem.  And of course it's a turnout where I really need to see the light indicators.  I guess I should contact Dennis and ask about the numerous dead switch motors I've accumulated over the past 5 years.  Got a box of them.  I have not tried swapping out the switch motor.   I'm sure it's 14V ac feed, Phil.

With the ones which needed a relay I found I needed to cross-connect the switch motor buss ground with the track power ground, or it didn't work.

Last edited by Kerrigan

Kerrigan,

It sounds very much like the non-derailing rail is not isolated from the main outside  rail at some point.

Do yourself a favor, build a small switch machine test stand to test the switch motor and controller.  That way you can isolate the problem quicker.  See attached photo.  The red/black wires off the terminal block are where you supply the 14VAC to operate the switch machine.

IMG_4944

bruce

Attachments

Images (1)
  • IMG_4944

Add Reply

Post

OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)
www.ogaugerr.com

×
×
×
×
Link copied to your clipboard.
×
×