ZW 6-32930 will not program

Well I tried the hold the button in for a time and got nothing. tried

holding the button in then power the brick which powers the transformer, light flashed but it would not program tried with handles on and off. It puts out 18+volts. tried TMCC and legacy, still no luck        Thanks for the Ideas. 



Something wrong then. If you can get to the switch and short the terminals, that would be the next test. Other than a poor switch, I think it might be hard to go further.

What was the issue with using Legacy that required a new programmed chip inside? Anything to do with this problem?


Ok, holding - the button in while powering the transformer is the output calibration procedure to zero all handles. All handles to minimum position. Press and hold button and power transformer.


using Cab 2 or Cab 1. There was one  scenario that you needed a power master bridge...

Remove the cover and verify that the jumper is in the 4 handle control position

I , too, suggest that you zero all handles and perform the calibration procedure

This is like rebooting your computer

I didn't have a T handle tool, which is the Lionel uncoupler tool and found a sharp pencil was too large. So, I used a small jeweler's screwdriver to push and hold the button.


Arctic Railroad


Photos (1)

I have one of these ZW's and the reset button is bad.  Of course, I found out it was bad after the board was no longer available.  I've never had to reset it, but I've wondered about replacing the little surface mount switch with some sort of push button external to the board.  Would not be a fix for anyone to try as you could not do the soldering job with a Weller gun.  I was trained in surface mount work in the Navy and have done it with the equipment I have.  Of course, my eyes aren't what they use to be nor are my hands as steady.  

Maybe GRJ or someone else has an idea?


Add Reply

Likes (1)
repair technician

OGR Publishing, Inc.
33 Sheridan Road, Poland, OH 44514