ESU cabcontrol program non-ESU engines?

I recently purchased an ESU Cabcontrol, mainly because of the recent Atlas F-3s having ESU decoders/sound, as well as the upcoming SWs. Because the F-3s have RailCom, the ESU cabcontrol immediately recognizes the F-3s, and you can change the DCC address of the engines basically on the fly, effortlessly. 

Then I added an Atlas RS-1 with QSI decoder, and it was easy to add the engine to the ESU cabcontrol and control the RS-1 using the default DCC address 3.

However, I have two RS-1s that I would like to run, so I need to change the DCC address of one of them. I have read the ESU documentation, and watched their instructional videos, and it appears to be fairly straightforward. 

However, when I try to change the DCC address, I repeatedly get a “programming failed” message. I can’t read the address, or set the address. I’ve tried it on the main, I've tried it on the programming track, but I keep getting the same error message. 

Does anyone have experience with this? I’d really like to get this working, because it’s a pretty cool little remote!

Jay

Original Post

The problem is that CV62 can not be set to ANY value because no matter what CV you try to set the ESU CabControl says “programming failed”. Can not read or write ANY CV value. 

I just never realized this system was so proprietary (would only work well with ESU locos). 

Jay

I have two Atlas RS-1s with QSI. Both operate fine individually using the ESU Cab Control on their default address 3.

With my M&StL I tried first following the instructions with the ESU trying to make the DCC address match the cab number, 233. Went to "DCC Address", tried to set, not only didn't work, but repeatedly got the message "programming failed". Tried unchecking the option "verify cv", but that did nothing. Tried unchecking the option "XL mode", but that did nothing. All the while I was mindful of the "bug" in the software and tried to hit "save" instead of hitting "done".

Went to the Atlas documentation, and followed their steps instead. Says to turn off "verbal acknowledgement", so I set CV62 to 0, but I don't know if it ever actually got set, because the remote just tells me over and over and over again "programming failed". Then I set CV29 to 38, but I don't know if it ever actually got set, because the remote just tells me over and over and over again "programming failed".

I go back to drive mode, and the loco responds fine with DCC address 3, so basically nothing was changed. Repeat ALL the steps above, over and over again, in different orders and configurations, and somehow it finally worked, and the M&StL is working with DCC address 233 (this was two nights ago). 

Tried to replicate the procedure with my other RS-1, SF #2394. I try over and over and over again, and can not replicate the apparently random sequence that generated a working result with the M&StL. In fact, after attempting to set the DCC address, I get to the point were the engine won't respond on ANY DCC address (3, 94, 2394).

So I take it to a separate DC only track, reset the decoder. Put back on the ESU track and repeat the steps that I thought worked with the M&StL, but to no avail. I do this over and over again, very frustrating.

This should NOT be this difficult. Now I face the prospect of having to take my loco to my nearest hobby shop, about an hour away, to ask them to please program my engine with DCC address 2394.

Oh, and about 30 minutes of my efforts last night were with RailCom turned off. But I pretty much took that advice with a grain of salt because I did not have to turn off RailCom when I eventually got the first RS-1 set up correctly.

Kind of missing straight DC at this point!

Jay

Well, finally went off script - ignored the Atlas instructions, ignored the ESU instructions - and tried programming old school on the programming track.

Reset the decoder then put on the programming track. Set CV62 to 0, set CV29 to 38. Then set CV17 and CV18 to the appropriate piece of the long address I desired. 

Done. 

Works fine!

NOW I need to get a booster, because running 2 powered RS-1s and 3 powered F-3s and 12 lighted CZ cars is a bit much for this 7 amp system. 

Jay

When in doubt, use a programming track.  Even though almost all modern decoders and command stations no support programming on the main, I'm building my layout with a programming track for the very issue you had, knowing that sometimes things just won't go like you want.  Glad you got it sorted out.

Add Reply

Likes (0)
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
×