Skip to main content

hellow again, so I have a MTH wifi unit that I am adding or should I say tring to add, I hooked it up and programmed the IPad and got it connected, added 3 trains and after that it said I need to upgrade the software for the Discovery unit, but it's not a Discovery  unit, I deleted it and reset it and still get the same message, any ideas as to why it thinks it's a Discovery ?

Original Post

Replies sorted oldest to newest

I had it on an IPad and it kept telling me no upgrade, so I put it on my phone and did the upgrade for 24.95, and was able to add all the engines onto my phone, then tried useing my IPad again and it would only see the 3 engines and would not allow me to do more engines, but my phone allowed me to do all the engines, so not real sure why it is happening

so not sure why it is doing this, hoping I don't have to do the 25 dollar upgrade on each device.

No, when I tried to get the upgrade on the Apple IPad it told me nothing was available, then I loaded it on my phone and did the upgrade on that

As long as the iPad is on the same Apple ID, go into the MTH App and select

  • more (bottom right on the app)
  • Upgrade

As long as the iPad is using the same Apple ID the upgrade should load without needing to  purchase it again.  If I recall correctly this was the path I took to get the premium app.  Regardless though once you purchase an App on a Apple ID, it free to devices using the same Apple ID.

Last edited by MartyE

Add Reply


OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)

Link copied to your clipboard.