Skip to main content

Replies sorted oldest to newest

First, did DCS recognize the engine when you tried to load it in your remote? 

If not, check your engine switch setting positions for DCS and 3 Rail (presuming that's your track).  Cycle those switches a couple of times and be sure you leave them in the DCS and 3 Rail positions and try to load it again with your DCS remote.  If it loads and starts, problem solved.

If DCS is still not recognizing the engine, or it is losing the address, clean the pick-up rollers and your track section.  Then, with power off, put the engine on the track.   Then energize your track.  Your engine should not start and will be off still.  Tilt the engine over slightly to one side until the pick-up rollers are off the track.  Then lower the engine back down on the track.  The engine sounds should start up in conventional mode.  If it doesn't, you may have a bad capacitor or bad board and need warranty service.

I had the same problem with a new 20-20635-1 in January (which turned out to be a bad board) and I took it to MTH Service in Columbia, MD.  Coincidentally while I was there, a fellow came in with a new 44 tonner with the same problem you describe.  A Service Tech met with the gentleman there in the waiting area and performed the test I described on the MTH test track there in the waiting area.  The tech told the customer he thought it to be an underpowered or bad capacitor.  He said this was a known problem on some of the delivered 44 tonners recently. 

I received excellent MTH warranty service with a three week turnaround.  I presume the other fellow received similar results.

Hope this helps and good luck.



Last edited by RidgeRunner

Add Reply

This forum is sponsored by MTH Electric Trains

OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
800-980-OGRR (6477)

Link copied to your clipboard.