Skip to main content

Morning gentlemen (and ladies): It is Saturday morning here in the "Land Down Under", and I have a problem with the most recent addition to my American steam locomotive collection.

I purchased this MTH Railking Camelback from a collector in the States, and it finally arrived a couple of weeks ago after its long journey. Unfortunately time and unforeseen circumstances (caught in a 14 day Covid lockdown in another state....don't get me going!!!) has prevented me from putting the loco on the layout to see how it performs, until yesterday.

I know it is a PS2, and it has the funny double AA batteries, but the manual said to sit it on the tracks, apply power up to 10-15V for 15min and see if the sounds are muffled/distorted, or if the start-up sound is normal. Everything seemed to check-out, and the start-up sounds were clear and distinct. The loco moved forward from the neutral start-up position when the power was shut down and fired-up again, and was easily controlled using the Direction Button on my transformer, moving back into neutral, and then into reverse. I run all of my MTH diesel and steam loco's from the transformer this way in conventional mode. Yeh, I know, I am a dinosaur from the Jurassic Era, just ask my kids!!!

Anyway, the problem I have is the dang fooled whistle just keeps blowing constantly, be it in neutral, forward, or reverse. I can't get the whistle to shut up no matter what I do!!!!!    The whistle does seem to drop off some if I increase the speed of the loco and get it up past 15V, but the loco is going too fast for my liking, and for the layout of my track.

The other thing I found is the electro-coupler at the rear of the tender won't fire open, no matter how carefully I follow the instructions in the manual - 1 press on the BELL button, followed by 3 presses on the HORN/WHISTLE button.

I even tried to do a "Factory Reset" following the instructions in the manual - to no avail!!   I never hear the "two horn blasts" the manual describes to confirm the engine has made the change. In the end I gave up and carefully wrapped it back up, and put it back in its box where it and I cannot harm each other.

Can someone with a lot more knowledge of these things (rituals in black magic) point me in the right direction........or is it a case of the PS2 sound board being stuffed!!!

I have attached photos of my "troublesome child" with and without the body on the tender, as well as the info on the carton flap, and the type of Lionel transformer I am using.

DSC02359DSC02357DSC02360DSC02362DSC02364

Thanks to anyone who wishes to enter my nightmare........Peter (Buco Australia)

Attachments

Images (5)
  • DSC02359
  • DSC02357
  • DSC02360
  • DSC02362
  • DSC02364
Original Post

Replies sorted oldest to newest

I can tell you the RS1 transformer and Ps2 electronics are incompatable.

This transformer/boards incompatibility thing does come up; it is not common now, but some transformers/some boards/some brands...that old Lionel (brand is not the problem)  xformer you are using may well be the culprit. Wave forms and all that.

(For future reference, many early MTH PS1 (not 2 or 3) will act strangely, or not act at all, when you attempt to run it with a modern xformer, even MTH's.  It requires a PW-style xformer. Sort of the other side of the coin from your current issues.)

Not as bad as it sounds, though. You need to get a modern transformer, like an MTH Z-500/750/1000. Keep the old one for when you need it. I run TMCC command; running some things in conventional these days can be problematic, i understand.

Thanks for all of the replies.

Soo Line: Yes, I have cleaned the track, and the rollers, and the wheels of this loco with denatured alcohol (we call it Mentholated Spirits here in Australia). I am now leaning toward something to do with the transformer. I recently received another giant American steam loco I won on a Stouts auction at the end of January.....a Railking Cab Forward with PS1. This behemoth runs perfectly using the same Lionel transformer, as do all of my other PS1 diesel loco's.

Chuck Sartor: Thanks for the info. The MTH instruction book that came with the Camelback clearly shows this transformer (Lionel RS-1) listed in their chart at the end of the manual as being suitable. I am starting to believe what you say may be right. Thank you.

D500: Thanks for the explanation on transformers and their abilities, or inabilities in this case. As I have mentioned, I have no trouble running all of my other MTH Railking PS1 diesel loco's (all 12 of them) and having the horns, bells, and couplers open using the horn/whistle and bell buttons. I will take your advice and see if I can get one of the MTH transformers you have suggested, and "retire" the good old faithful Lionel RS-1.

Richie C: That is the interesting thing......the owners manual clearly shows the Lionel RS-1 is compatible with this loco. It fires the loco up, the protosound startup in neutral begins, the whistle starts blowing (on and off constantly), and then when the power is shut down and brought back up, the loco starts moving in the forward direction, as it should. The speed of the loco is controlled by the position of the handle on the transformer, all the while with the whistle constantly blowing.....very annoying!!!!!  I think D500 has hit it on the head, this transformer does not produce the required Sine Wave to send all of the messages to the circuit board. This is the first PS2 Railking loco I have in my collection, and it is the only Railking to have a problem with my transformer.

Thank you for all of your replies, and now I am on the look out for a new/second hand MTH Z-750 that wants to reside in Australia.

Peter.....Buco Australia.

UPDATE!!!!!

Chuck Sartor and D500......you were both soooooo right!!!!!

I went foraging in my transformer storage bin yesterday and found I had a brand new MTH Z-500 in there. Bought it years ago when I was getting back into the hobby (along with a coupe of Lionel transformers), and clean forgot about it until now.

Temporarily wired it into the layout just to perform a test on the "Camel back" and, low and behold....the dang fooled thing works just fine!!!!

The Camel back makes all of the normal start-up sounds, minus the whistle constantly blowing, and is easily controlled from the transformer. The whistle blows only when I hit the whistle button, and the bell rings when I hit the bell button.

And the best thing yet........the coupler at the rear of the tender fires open when I hit the bell button once, followed by the whistle button three times!!!!!!

I even tested one of my PS1 diesel loco's to make sure it would function correctly, and everything worked perfectly. Who would have thought that all this trouble and strife could originate from one little transformer.

All is well in "the land down-under"now!!!!!

I have a job in front of me this coming weekend to remove the Lionel RS-1 and install the MTH Z-500 on the operating deck.

Thank you guys once again for pointing me in the right direction.....I am one happy camper.

Peter.....Buco Australia.

Peter , do you have a good photo of the bottom of the tender ?      I'm a little confused (  my normal  mode )

The charging port on the bottom of the tender for the proto 2 -3 volt board is a two pin port for the MTH Charger ...........the 2  batteries in the green wrap in your photos looks like my 2.4v  700mah  NI-MH. that I use for my 3volt proto 2s.

..........however........

When I  went to the MTH site for the engine number  ( 30-1399 )on your box and tapped on the SUPPORT  icon , I  downloaded the manual . 

On page 13 it stated that the battery was a  7 cell 8.4 volt .   It showed the bottom of the tender with only the one pin port.   The best info I have is that engine would have a proto 2- 5 volt board .

Possibly could be a wrong manual on the MTH site . 🤔      If you have the two pin port on the tender then I would have to say that green battery is the right one. 

Buco - Congrats on getting your engine working and Thanks for your reply Post letting everyone know how you made out.  Unfortunately not that many do so, and it's too bad because I'm sure that besides myself there are many others who would like to know how different issues turn out.  After all, that's how we learn.

Good Luck and enjoy running your new engine but - most of all - stay safe!

Possibly could be a wrong manual on the MTH site . 🤔      If you have the two pin port on the tender then I would have to say that green battery is the right one.

The picture of the PS/2 board is clearly the PS/2 3V board, so the battery is correct for that board set.  Obviously, the manual at MTH is incorrect, at least for this particular sample of one.

Hi Dallas:

I have attached a couple of photos of the bottom of the tender and the charging port. You and Gunrunner John are correct in that it is a PS2 3V board.

When I had the body off the tender trying to work out what was wrong initially, I checked the battery and thought it was 2 AA cells, but on closer inspection it has 2 AAA cells. Does this make any sense to you?

Questions: What type of BCR will I need to replace these AAA batteries......will a BCR2 be the one to get?

Is this the PS2 board that gives all of the trouble????

DSC02396DSC02403

Peter.....Buco Australia

Attachments

Images (2)
  • DSC02396
  • DSC02403

Thanks Chuck and Dallas.....I've put my order in for 2 BCR's and 2 BCR2.....I like to have at least one of each in my spare parts bin, just in case I go mad and purchase another fantastic MTH Railking PS1 or PS2 loco I have on my "wish list".

Thanks again guys, that's what makes this forum so great......helpful info even if I am halfway around the world on a small island down-under.😎

Peter.....Buco Australia

The MTH AAA battery packs are horrible. They rarely hold a charge and fail prematurely.  Measure the voltage at the charging port and if it's not 2.5+ volts, it's not going to work. If you don't want to use a BCR, buy an AAA NiMh cordless phone battery on Amazon, change the end on the battery (cut off the one from the old battery and observe the correct polarity).  Have replaced dozens of these batteries successfully.

Thanks Jon:

I measured the voltage output, and yes....I am getting around 2.6-2.7V on the multimeter. The loco performs the start-up sequence as it should, and the sounds are clear and not garbled. It also goes through the shut-down sequence as it should, with that tiny little "fart" just audible right at the end.

I placed an order for 3 BCR's and 3 BCR2's this morning, and I am now waiting for confirmation, but probably won't get it for another couple of days seeing it is Sunday here in Australia, and you guys in the States are just going into your week-end.

Thanks for your help and advice Jon, and we can all sleep well tonight knowing the PS2 3 Volt circuit board is not about to commit Hari-Kari in the immediate future.

Peter.....Buco Australia

Add Reply

Post
This forum is sponsored by MTH Electric Trains
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×