Skip to main content

I was given this set without a manual and showing very little track time.  I noticed the engine wobbling going down the tack and after close examination I noticed the drive rods hitting the shell at the top of the wheel rotation.  I contacted Atlas requesting a manual to find out how to remove the shell.  Their only reply was;  "remove 6 screws, we have no further information".

So I removed the 6 screws and ground down the shell with my Dremel and that solved the problem.

My questions are, has anyone else had the same problem ?  Do you have a manual you would share ?        Does this engine have a reverse ?  mine only goes forward.  It's a decent puller (3 passenger cars) ,  whistle and bell work and a good smoker.  How old is this set ?

2021-07-26 005 [1024x625)

2021-07-26 007 [1024x499)

2021-07-26 003 [1024x441) (1024x441)

Thank you in advance for and info you may be able to share,



Images (3)
  • 2021-07-26 005 (1024x625)
  • 2021-07-26 007 (1024x499)
  • 2021-07-26 003 (1024x441) (1024x441)
Original Post

Replies sorted oldest to newest

Many 'round-the-tree special sets left the rev. unit out to lower cost/increase profit, as these sets  were not really "model" railroad item. One could be added inexpensively.

These PRR E-6 Atlantic models are really quite good representations of the prototype. The tender is accurate and appropriate, too, right down to the Pennsy tender trucks. The locos running gear falls down in that department with the rods/valve gear (missing)/drivers.

So far as I know the loco/tender are O-gauge but S-scale. I never put a ruler on them, but I imagine that a few have been mounted on S-gauge mechanisms by the Flyer and S-scale bunch. The castings are quite good.

One thing you could try with your existing transformer is to cut the power completely by holding the direction button down for several seconds. I have noticed the light on the locomotive fades slowly when I push the direction button, possibly the result of the locomotive’s capacitor circuitry. Any quick presses might not be enough to bring the voltage down to zero, which this e-unit seems to demand.

And there is no direction-lock switch on this model. The only switch is to turn the smoke unit on or off.

Today I tried another transformer ( Lionel CW80 )  and that didn't change anything.

I also tried Jim R.  suggestion of holding down the direction button for several seconds.  Most of the time it would stop the engine then it would start forward again.  However some times it would find neutral and shut down.  To get it going again I would have to kill the power to the track and bring it back up and it would start forward again.   

Not having a reverse really isn't that important to me, it will always be run on an oval and never see a switch yard.

Thanks again for all your reply's ,


Add Reply

OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
Link copied to your clipboard.