If I run it conventional, no problem. But on CAB 1, it runs a half loop and quits. Press the "R" (key #8) and it resets so I can run it again...til it stops. When it is stopped, no movement, but all sounds work. Reset and go again. I exchanged the R2LC board module, no change. I put ceramics on the motor brushes in addition to the 1uF caps, no change. Wiring looks ok of course. Just wondered if anyone has had experience with an ERR AC-DC where this happened and they found some cause that I could look into besides replacing the ERR motor drive board.

Chuck TCA LCCA ARRL BMWMOA

Original Post

This is a known problem with the R2LC in its latter stages of production.  The driver board is probably fine.  For some reason, the AC common through the wheel sets produce a bit more noise on some locos, which affects the R2LC and it resets.

 

The fix is to use an R4LC, with C08 code.  Please contact Ken at ElectricRR and he will arrange a solution for you.

 

 

jon

Lionel LLC (2006-2017)

Originally Posted by cjack:

OK, great. Thanks for the replies. I was thinking that I need some updates for sound too, so I'll get with them.

Thanks again.

Meanwhile, I have three R2LC08 cards, one of them resets with noise I guess (original one with the problem), one seems to be ok for running with lights and sound working, and one of them (the newest one from Lionel) seems to run ok, but lights and sound do not function. I don't think I've used this newest one...maybe I'll check the triacs, etc. in it...or maybe a programming issue.

And will get with ERR for R4LC08s. Do they just plug in without changes to the motor drive board? I see two selectable jumpers on the motor driver board...

Chuck TCA LCCA ARRL BMWMOA

You mean the R4LC. I did fool around with the 3 R2LCs that I have and one of them reliably stops when the engine goes a dozen feet. One seemed to lose lights, horn, and bell but has other engine running sounds...but then when I hit the "R", I got lights and no horn, bell. So I went carefully thru the whole programming again and got the horn, bell. But lost the horn, bell the next time I started up the layout. Oh well. I have never had so much trouble in any of the TMCC engines that I have had with this SD40 with the two AC motors in it.

It remains that I have one R2LC that seems to have all the features, and does not stall...so far.

I am looking forward to the R4LC.

Chuck TCA LCCA ARRL BMWMOA

Mine ran great when I put it in and then after sitting on the shelf for awhile, I ran into this problem. I don't know why it took awhile to surface.

I actually ordered 2 of the R4LC boards...$80. A friend may need one with a similar issue.

BTW, I figured out the sound problem was the sound card. V2.1 if that matters. I replaced it with another sound card V2.1 and then exchanged the feature chip in it to the one I wanted to use and the horn and bell are solid now.

So a sort of design issue with the R2LC and a faulty sound commander board.

Anybody know what the issue is with an Electric RR V2.1 sound commander board that seems to lose it's features and sometimes doesn't always program correctly? The feature chips which are 3.11 and 3.25 and both work well in a good board. I'm looking for another sort of design issue . One thing I find odd is when I press "5" to shut the engine down, the sound goes away instantly. I don't think I have any other TMCC engines like that. The others seem to take a few seconds for the sound to quit.

Chuck TCA LCCA ARRL BMWMOA

I wasn't aware you could program the sound commander board, the only programming I'm aware of is the R2LC (or R4LC) in any of the ERR setups.

 

Oh. I don't know how it works, true. Guessing. So the R2LC gets programmed and sends the selected sound feature info to the sound board each time you press a button. That seems right. So when my R2LC sent strings to the sound board, something was amiss in the sound board that it couldn't play the horn or bell. Wonder what...

Chuck TCA LCCA ARRL BMWMOA

Well, if the R2LC isn't the issue, the serial connection or the sound board would be my suspects.  I just fixed one that had a bad connection to the IR sensor for the wireless tether.  All sorts of odd happenings.

 

Well the new R4LC-C08 fixed it. The engine does not stop any longer by itself requiring a reset "R". So great. Thanks Jon. The new board seems to have some different features I need to explore as well.

Chuck TCA LCCA ARRL BMWMOA

Likes (1)
PRR2818
Post
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
×