Skip to main content

Calling on the TAS experts! I have a chuff issue with a TAS EOB. I’ve installed one in my AC-6 cab forward without any issues and it performs pretty well. I came across another one so I figured why not, right? It came out of a 3rd Rail B&O steam loco and included pretty much everything. It didn’t come with a motor but I have a few laying around so no big deal.  I set up the tach tap and reader as spec’d on one of my extra motors. Verified the LED blinked at every stripe. Performed a “reset” & set the parameters in the EOB.  Good to go, right? All seemed well and I started it up. All of the sounds work, F & R lights work, couplers work, smoke  works (using a TAS non turbo smoke unit), but the audible chuff is missing (note: smoke unit fan runs at a constant rpm too). I reestablished the AUX1 code and reconfigured the chuffs per revolution again and retested. Still no chuff sound.

I then looked back at the parts bag and found the EOB came with two sistered micro switches (I originally omitted from the test setup). Perplexed,  I jumped on the forum and researched the issue. I came across a few posts from GRJ and other members that explained the reason behind the lack of the digital chuff in the board and the purpose of the micro switches. “Ah ha”. This was a factory installed EOB. My other EOB is an upgrade board. They have different PIC chips. Problem solved!!! BTW, you guys have amassed a wealth of knowledge in the archived posts that amazes me. 

I went back to the test bench and wired one micro switch to the chuff input and ground. Tried it again by manually closing the switch but no success. I thought maybe the switch is bad so I tried the other one. That one seemed a little flakey so rather than check the switches with a meter, I just tapped the bare wire to ground to see if it would chuff. It didn’t. I did notice prior to this, when I powered off the transformer and powered it back on, it chuffed once when I turned the throttle wheel. This only happened maybe 3 times, definitely not every time. This happened sporadically with or without the switches wired. Frustrated, I pulled the entire setup apart and checked the board components for damage. I didn’t see anything so I put it all back together. Fired it up and it wouldn’t acknowledge the controller. Swapped out the R2LC with another known working one and same result. I then noticed my CW80 transformer’s light was blinking indicating a short. I unplugged everything again thinking a wire was pinched or something obvious. Nope. I then plugged in each component one at a time and cycled the transformer each time. The light stayed constant until I plugged in the R2LC board. I tried four R2LC boards and got the same result every time. It has to be the motherboard but I don’t see anything obvious. Sounds work without the R2LC so it has to be on the R2LC’s side of the motherboard. I haven’t probed the board yet but I figured I’d drop a post to see if anyone may know what’s going on. Anyone out there who may have some insight on this?  

Last edited by DanVW
Original Post

First off, the single chuff is generated by the RS board when you crack the throttle, that wasn't coming from the switch.

There was a way to inject the chuff from a switch into the TAS boards, Mike Reagan would know.  You can also inject chuff into the R2LC pin-17 directly, grounding that pin will generate the chuff.

Note also there are multiple versions of the TAS EOB boards, and I'm sure there's lots of wrinkles that few know about all of them.

Mike,

Thanks for the info. I already have the installation manual though. The steps you mentioned are the steps I completed initially and again after I discovered the chuff issue. John hit the nail on the head with the PIC issue due to a patent dispute with MTH. The “diesel” chuff rate was programmable in the aftermarket EOB’s to allow the smoke fan to slow at idle and rev up while under way without creating an audible chuff. 

John,

The microswitches came attached to a male plug and an additional switch to select between 2 and 4 chuffs per rev. I believe one of the axles had two cams originally. One had 2 lobes and the other had 4 lobes. The micro switch plug connected into the 4 pin smoke socket and the wire was aligned with the chuff pin on the board. I’ll have to take a closer look at it later tonight. Thanks again for your input!

Add Reply

Post
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×