Skip to main content

Replies sorted oldest to newest

It sounds like you're operating in TMCC mode. As Richie mentioned above, make sure the "figure" switch is moved forward for "run" mode.

If your locomotive won't reverse, but all other commands (Forward motion, rear coupler, missing firing) work OK, then you may have a board problem.

But first, try to reset/restore your locomotive using the procedure found on Page 13 of your owner's manual: https://www.lionelsupport.com/...ents/72-8411-250.pdf

NOTE that the manual has an incorrect code: instead of 8, use a 5 if you'd like to have the red rooftop light flash, or a 6 if you'd like it to be on all the time.

If this still hasn't fixed the issue, then chances are you have a problem with your R2LC or ACDR board found inside.

TRW

@CanadianCN posted:

Hello TRW, 

I want to confirm a few things in you message.

You mention a wrong code. Is this for the light or when I follow the reset procedure on page 13 step #8 to enter the #8 as a code. I want to make sure I am doing correctly the reset.

Thank you 

CN,

Basically, it’s both. The codes I gave you (5 or 6) are for a reset/restore of your locomotive’s electronics. This also sets the function of the light on top of the cab. The 8 code printed in the manual is wrong, as that’s for a diesel with smoke. So follow the procedure on Page 13 but enter a 5 or 6 (your preference) instead of the 8.

if that doesn’t improve the situation, try operating the loco in conventional mode (unplug your TMCC base) to see what happens.

i don’t believe an unusual R2LC is found in that loco, so it wouldn’t be a big deal if that needs replacing. Same thing with the ACDR.  The motherboard, on the other hand, is a unique animal to handle the missile firing, but that shouldn’t have anything to do with direction control.

TRW

I have followed the reset with both numbers provided above and now the engine does not move forward or reverse. The red light flash and turns off when using the remote. When using the direction button the forward light turn off and back on if direction button is pressed.

Firing button from remote works. Will not move in conventional mode.

Wow, no luck here for me.

Hope someone can assit.

Thank you and stay safe

Well, I'd check the obvious first.  Look the motor over and see if you have any issues there.  Unplug the motor connection from the ACDR board.  Measure the field (green wire) to ground, it should only be a couple of ohms.  Then measure between the brushes, that should come in at 3-4 ohms.  Rotate the armature while taking the reading, see if it ever goes to infinity.  You can also test the motor with AC power from that plug.  Connect the field to one of the brush leads.  Connect the frame ground to one side of the transformer and the remaining brush lead to the other side.  Apply 6-8 volts from the transformer and the motor should rotate.

If it's not the motor, and you've verified the connections from the motor to the ACDR are good, you likely need a new motor driver (ACDR).

It's time to get further into the weeds. As John mentioned above, I'd start with giving the motor a good once-over to verify all is well there. Once that's done, move onto the wiring and electronics.

Based upon your description, the ACDR motor driver is suspect, but it's important to go over the motor to be certain nothing there caused the ACDR to fail in the first place. Or it might be something else... we're kind of at the limits of what can be diagnosed remotely.

If you're uncomfortable with going further, I can have a look at your locomotive, or I'm sure John or others on the forum can do the same.

TRW

If the r2lc has unique code, you can still get it. You would need to contact lionel. They can burn the correct code into the r2lc. My whale aquarium car had a r2lc that went bad. It had whale code. Lionel programmed a r2lc with the correct code for me. 

A friend of mine has the missile launch set. His engine had the r2lc go bad. I put a new standard r2lc08 in. Works perfect. Not sure if the army version is different.

@Joe Fermani posted:

If the r2lc has unique code, you can still get it. You would need to contact lionel. They can burn the correct code into the r2lc. My whale aquarium car had a r2lc that went bad. It had whale code. Lionel programmed a r2lc with the correct code for me. 

A friend of mine has the missile launch set. His engine had the r2lc go bad. I put a new standard r2lc08 in. Works perfect. Not sure if the army version is different.

Hi Joe,

At this point I am not sure what part is not functioning. I know that someone offered to assist to find actual defective part. Will keep you all posted. You are all great for assisting me in this time of need.

Stay safe.

Add Reply

Post
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×