I have two k-line ep-5 engines and a Lionel gp-38.  All three engines have Lionel tmcc.  All the engines accept the program code and all the features work.  The problem is that all of the engines go to full speed when you just turn the red button a little bit and they will stop when you just turn the red button  backwards.   There is no variable speed.  I think the problem is with the motor driver board.  Does anyone have a schematic of the board or any other ideas that might help.  THANKS

 

Original Post

It would help to know the exact K-Line models.  However, your issue sounds indeed like these units have K-Line Cruise and something has gone wrong with the cruise module.

First step would be to verify the integrity of the wiring between the flywheel sensor boad and the cruise module.  If that's good, it's likely the cruise board has died, this is a pretty regular occurrence with the K-Line Cruise boards.

The fix is typically to replace them with the ERR Cruise Commander M as K-Line cruise boards are long out of production.

Your correct John, all three have cruise control.  The two k-line boards look exactly as the Lionel board.  That board seems to have common components.  Is there a electrical diagram of these boards available?

The K-Line with cruise uses the same three Lionel boards, the R2LC, the RailSounds audio, and the RailSounds power supply.  However, instead of the DCDR motor driver, they have the K-Line cruise board.  That's usually the troublesome board. Here's a clip from a thread here, the K-Line cruise board is at the top, and the ERR Cruise Commander M is at the bottom.  The CC-M is what we typically use to replace the K-Line cruise.

Attachments

Images (2)
Last edited by gunrunnerjohn

Add Reply

Post
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
Link copied to your clipboard.
×
×