Look closely at the photo in this link: https://www.amazon.com/William...ams+by+bachmann+rs-3

Call me crazy, but I see coil couplers on this thing. Do Williams trains offer coil couplers now? Is the conventional True Blast Plus sound system multifunctional like old Proto-Sound 1, allowing coupler firing from conventional control, etc. ?


Anyone have any experience with Williams by Bachmann True Blast Plus locos and can tell me about them?

Original Post

It could be an old k Line RS3 that was painted as an engineering sample. Fwiw, I did a comparison of this wbb RS3 to  Weaver model. Just do a search. Anyway rest assured the WBB model does NOT have electro couplers or TMCC. You can still get the PRR version at a good price M.I.B. from forum sponsors

Weaver_vs_Wbb01Weaver_vs_Wbb03Weaver_vs_Wbb04Weaver_vs_Wbb05Weaver_vs_Wbb06Weaver_vs_Wbb07Weaver_vs_Wbb08Weaver_vs_Wbb09Weaver_vs_Wbb11Weaver_vs_Wbb12Weaver_vs_Wbb15

member:Golden Spike Club Charter Member

Attachments

Photos (11)
prrhorseshoecurve posted:

Who is foolish enough to pay that? I see them at an ogr sponsor for $200.00! NOW!

Definitely not me  I just wanted everyone to see the photo discrepancy, because for a second I was like "wow, way to step up your game Williams - conventional coil couplers??? not seen since the old QSI days, but cool!" .....Well, ain't that a bummer though. A bit of a let down. Maybe I should make a case out of "false advertising" and just mess with them for fun lol. Unfortunately, I don't have that much time on my hands...

Hate to bump this, but have a question if anyone available, got a good deal on a Williams RS3, BUT I'm not terribly experienced with Williams, when it arrived, the couplers are non-functioning and plastic, AND the rear has snapped off/is loose, plastic broke not the screw.  Are the couplers on these units just static and plastic?  is this an older model?  Can it be repaired? It does NOT have sound.  Thank you for any help!

SPSF posted:

Williams/ Bachmann shows two universal type couplers 293-E001

Check that your coupler doesn't have a screw plate where it mounts to the truck.

That would be the FA / NW2 type: https://estore.bachmanntrains....8durggva5b1o87meedl1

 

Or maybe here, https://www.ebay.com/itm/Willi...d:g:AkgAAOSww05dara6

 

ah, did you see my correction?  Turns out my loco is Quality Craft/Weaver, but same problem.  Its interesting too, the truck ends with the center rail power roller, not seeing anywhere a coupler can hook to truck.  You can see the dinky plastic coupler dangling there, was it meant to be just for looks and the modeler is to add their own coupler?  Thank you again!

Attachments

Photos (1)
D500 posted:

I think it was mentioned, but the photo is doubtless of the original K-Line iteration of their RS-3, or at least their trucks/couplers. Maybe an old K-Line photo or a newer Wms photo of an old K-Line loco.

 

Thanks D500!

https://ogrforum.ogaugerr.com/topic/kline-rs-3

If its KLine, that thread states a coupler upgrade is out there, BUT the letter in the loco box states its is Quality Models/Weaver?

 

Any link to a buyable coupler assembly appreciated

If that photo is your engine, it is a Weaver single motor.  The coupler does not attach to to truck, it is body mounted since the pilot is solid.  I may have some couplers with a thumb tack, mounts the same.  I have to look thru my parts.

Gene Anstine

grfd59 posted:

If that photo is your engine, it is a Weaver single motor.  The coupler does not attach to to truck, it is body mounted since the pilot is solid.  I may have some couplers with a thumb tack, mounts the same.  I have to look thru my parts.

Gene Anstine

It is my engine, and as you can see the thin plastic post has snapped right off  So there are couplers that mount using a thumbtack hack?  wonder if I could rig something up...........

Add Reply

Likes (0)
Post
OGR Publishing, Inc., 1310 Eastside Centre Ct, Suite 6, Mountain Home, AR 72653
330-757-3020

www.ogaugerr.com
×
×
×
×
×